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Problem description

Outline An end loaded ‘built in" cantilever beam is analysed to demonstrate
different analysis types (implicit and explicit) and different shell
element types available in PAM-CRASH

Analysis type(s): Implicit and Explicit, 2D analysis

Element type(s): Shell: Quadrilateral (Belytchko-Tsay, Hughes-Tezduyar), Triangle
(Belytchko-Tsay)

Materials law(s): Elastic

Model options: Boundary conditions, Nodal loads, Nodal damping, Hourglassing

Key results: Displacements, Convergence

Prepared by: Anthony Pickett, ESI GmbH/Institute for Aircraft Design, Stuttgart

Date: November 2007

Version: V4 (Updated May 2012 for Visual-Crash PAM V8.0)
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Background information

Pre-processor, Solver and Post-processor used:

e Visual-Mesh: For generation of the geometry and meshes.

e Visual-Crash PAM: To assign control, material data, loadings, constraints and time history
(control) data.

¢ Analysis (PAM-CRASH Explicit and Implicit): To perform the Finite Element (FE) analyses.

¢ Visual-Viewer: Evaluating the results for contour plots, deformations, etc.

Prior knowledge for the exercise
No prior Visual or PAM-CRASH knowledge is required for working through this exercise.

Problem data and description

v
i A
Units: kN, mm, kg, ms 1 50 30kN
H
Description: Plate 250mm*50mm, thickness 2mm ' v
First analyse using a regular 10*¥10mm < >
quadrilateral mesh (this will later be refined 250

to 5*5mm and 2.5*2.5mm for the convergence study).
Loading: Imposed total load = 30kN (this is to be distributed at the loading end)
Material:  Steel (E=210kN/mm?, v=0.3 and density 7.8*10°kg/mm?)

Supplied datasets

No datasets or meshes are needed to tackle the problem; the mesh will be generated as a part of the
exercise.

It is recommended that you use the following names for the PAM-CRASH input and results files:

For the elastic cantilever 10 mm mesh use Cantilever_10mmMesh.pc
For the elastic cantilever 5 mm mesh use Cantilever_5mmMesh.pc
For the elastic cantilever 2.5 mm mesh use Cantilever_2.5mmMesh.pc

In each case completed PAM-CRASH datasets are available in case you get into trouble.

Background information: Solution methods and geometry

Implicit versus explicit analysis: The PAM-CRASH code is a general purpose three dimensional (3D)
code for implicit and explicit FE analysis. This exercise performs implicit and explicit analyses of a
simple two dimensional (2D) structure with applied force loading.

Explicit analysis treats the structure as a dynamic problem and solves dynamic equations of motion in
the time domain; it is especially efficient to solve crash, impact and similar dynamic problems,
particularly if material non-linearity (plasticity..), large deformations or contact occur. For explicit
analysis you will find all nodal and element quantities given with respect to time.

Implicit analysis (usually) assembles the structure stiffness matrix to solve static loading problems that
are independent of time. Material non-linearity, large deformations and contact are possible with non-
linear solution methods. The exercise will include an implicit geometrically nonlinear analysis.

Geometry: The PAM-CRASH code is usually only applied to 3D structures; there are no special
capabilities for 1D or 2D geometries. For this exercise the 2D cantilever beam is analysed using shell
elements with appropriate loading and boundary conditions to make it a valid 2D problem.
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Part 1: Using VCP to make the cantilever beam model

Preparing the mesh (Visual Mesh)

Start the Visual Crash Program (VCP) and under the
Applications tab select the Mesh option.

This will activate the meshing module (Visual Mesh) of
the VCP program which is dedicated to generating finite

81 Visual-Crash PAM 8.0 - Home Page

I VM

Eile Edit View

utive
FICN
=1 M =

Node 1D 2D 3D Assembly Weld Tools Cras

element meshes. e
Select the option New file then specify the model unit
system:
. I . Change Unit System = @

e Set Source Units to mm, kg, millisec, kelvin S — oeor

e  The target units will be the same Sptems ||| UNKNOWN UNKNOWN v

. Click OK Length FM FM v 1
This specifies the unit systems (kN, mm, kg, msec). A units Mass K& K& 4 | |
conversion to a different system could be made if needed; Time MILLISEC MLLSEC v | |
we use the same for both. Temp: | [KELUIN KELIN v

Ok Cancel

Alternatively, an old or partially completed model could be
read in for further working using Open File and specifying
the name of the file.

Some general comments before starting

Most mesh generation programs either allow the mesh to be generated by construction information
(points, lines, surfaces, volumes, etc.) or use surface and volume data from CAD packages such as

IDEAS and CATIA.

We shall generate the mesh here using some simple construction features in Visual-Mesh. The usual

procedure is:
e  Specify key points in x,y,z coordinates.

e Join these points with lines, arcs, circles, spline curves, etc.
e Use these lines as a basis to construct lines for 1D elements, surface (patches) for 2D

elements, or volumes for 3D elements.

e (are has to be made during this process to make sure the generated mesh is appropriate to
the loads, boundary conditions, part and material groupings that must be specified later in the

process. Some advanced planning is needed!

Note: Visual-Mesh follows similar steps to make the mesh, but some useful tools are available to

help simplify and speed the process.
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Planning and specification of (nodal) points
(0, 50) (250, 50)

The cantilever has four points that must first be
defined. It is arbitarily chosen here that this model lies
in the x-y plane with one corner at the origin (x=0,
y=0) and the other points having the coordinates 0. 0) (250. 0)

shown; (z=0 for all points). y
[

Defining the (corner) points

I Visual-Mesh 8.0 - Documentl vdb
Applications  File Edit View Curve 5Surface Volume | Node | 1D 2D 3D  Assembly Checks Tools

’ ._nfn BIOBD0E DG G QAL

Between 2 Points

The four corner nodes are defined using
the Node > By XYZ, Locate... panel in s
which the coordinates for each node are ’ ¢ [y L By Curve Intersection

Selection

Standard

entered and the Apply tab is clicked. The { = EEDS =H BEER0 %506 i;j:(f”"“ﬁf;ﬁif‘;”;?f T
default ID numbers are used. S [xCr] (i —
Align Center of:
i [¥E PoR [#3 B [85 Part ([ Gb | ;“; MidNo| =~ O locte O caof:
For the four nodes use a z=0 coordinate B & QUEFH| ] crestepoims .
Document.vdb v Create Nodes L
value. Note that the node ID numbers CEa— et v.[o
and their sequence are not important to el — z[o
. {= Nodes (N} Entity Type
the exercise. 1@ Hemerts () @noze
: Q) Point StartID: | 1
Unda
reset | L sppty || cose |

POSitioning and VieWing options: B2 Visual-Mesh 8.0 - Documentl.vdb

Applications  File Edit View Curve Surface Volume Node 1D 2D 3D Assembly Checks Tools M

LEB | PP FIGES FL-OF¢ LE8Y &,;‘:‘

Important options are available in the
main (top) panel to position, center, {
zoom (in and out) and gererally vary ’ BasicEnty | R |6y (v | BasicEnt) K [ %/ ¥ Ao oty 5

- e
viewing of the model. Gty /

Standard Views

1. Click the axis tab and with the ‘left’ 1) (2)
mouse key to open options to S Re |+
position the model in the x,y,z or i Lix © % & g R
perspective (isometric) frame. oz h:*z;:::s:s:’ K4 T/ @ *IEE“ ?EF ﬁ —

rg,er Isometric View

SQaE »

i

2. Click the viewing tab with the ‘left’

. """er Top View 1 L
mouse key to open options to = _ Add or Remaove Buttons b
. o —— 1 Front View
zoom infout and generally position M o
@ Ly Left-Side View
the model. = .
Pyl Bottomn View

Spend 2-3 minutes to be familiar with =L, RearView "
these options; they are important. Use 1 Right-Side View

tab options (1) and (2) to center and
position the model in isometric view.
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Generating the mesh surface

3/4 Paint Mesh

Activate the 2D > 3/4 Point Mesh
tabs with the 4 point polygon option.
Starting at any point click on the four
corner nodes in sequence (clockwise or
anti-clockwise). Note it may be
necessary to use the previous
positioning and zooming options to
suitably position the nodes in the .
viewing frame. On clicking the last node T
the surface is generated as shown.

@ 4Point Polygon

© 3 point Folygon

Generating the mesh EreE y -J\ -
® 4Paint Polygon @ Point ’ -

Click on the Create Mesh tab and a new G
panel opens to control the mesh to be — ) : P

generated. Element sizes, grading of e e loam ]| RS e
meshed and connection options (stitching) ™ | [

2D Mesh @[%][=

Count
Count: | 4 [} settoEdge

to possible adjacent meshes can be < o —
defined. el A

O count

Biasing

Use a 10mm element size and click the tab i e [ega ] e

. . [ Fip [ pasEdge | settoAl
Create h{lesl?. The mesh will appear; 1 —
accept this with the OK tab and then y
Close to close the meshing panel. me | RG]

e =
N VS CreateMesh
<

Ending the Visual-Mesh work

This now completes the meshing work with Visual 5] Brport = Lo
Mesh. Save the data with File > Export to a Export

File Mame: | Cantilewver_10mmbd esh.pe w

suitable folder with a suitable name. Use the Ditectoty | \JsershionyDeskiophTemp Training i
extension .pc which is the default name for a PAM- Expart Order

Aslmported W || PAM-CRASH Files [ pe..ps. inc, pox]
CRASH dataset. - E—

Export Options

. [Jwisible  [«] Header [v] Contrals [ Ewpandrange I Pos file
E.g. a suitable name could be P

Cantilever_10mmMesh.pc =T

Remark: It is possible to use the File > Save option to save data in a binary (.vcb) format, which
could be useful for large models and stores additional detailed information such as CAD
data and meshing information. However, PAM-CRASH only accepts the ASCII (.pc)
format and so this is used as the basis to store data throughout these tutorial exercises.

Closing VCP-Mesh
Use File > Exit to close the meshing session.

Remark: In priciple you could directly continue with the next operations to define entities, materials,
etc., by switching back to Visual Crash PAM (Applications > Crash PAM) and continuing.

But it can be advisable stop, copy the dataset created to have a safe backup of the
meshing work and then continuing; we shall do it this way.
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Defining the model data (Visual Crash PAM)

Preparation of the model(s) for analysis

This involves:
e Starting Visual Crash PAM for definition of entities (Loads,

boundary conditions, etc.,)

¢ Application of boundary conditions (fixed restraints at the built-
in end). N
e Application of loading at the opposite end.
¢ Definition of part (geometric) and material (mechanical) data.
¢ Definition of the PAM-CRASH control data (type of analysis —
implicit or explicit) and other parameters.

Copying files and starting Visual-Crash PAM

Copy the mesh file just created to a new name and work with the copied file. If things go wrong you
could then go back to the mesh file and start again. Note there are no ‘UNDQ’ capabilities in VCP; but
you can always delete options and redefine then.

Copy Cantilever_10mmMesh.pc to Cantilever_10mmModel.pc.

Start the Visual Crash PAM and read in the new file (Cantilever_10mmModel.pc) using Open
File.

Furtherviewing options Applications  File Edit View Curve 5Surface Volume MNode

Useful options are available in the main El=; =":@ JOFIDIHIR G

Standard

control panels for viewing the structure
(wireframe, polygon...).

Try these and then activate the
‘wireframe’ option.

Positioning and centering of the

Node 1D 20 38 Fstembly Checks Tools Mocro Window Help
/

model b IO e R &2 =W T O O ORA T anal
[ c- ‘ J Selection I
Use the x-y and centering tabs to REK i¢?
. s P f’e:::ﬂz%he\w -o
conveniently position the model as N
shown. This will make assignment of o o S

the bounday constraints, loadings and
other data easier.
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Boundary conditions (fixing the
built in end to the wall and other
constraints)

Click on the tabs Crash > Loads >
Displacements BC to get the panel
to assign nodes and boundary
conditions. Use the left mouse key to
drag a box over all the nodes at the
left end (minus x direction) and click
the green arrow to assign these. The
selected nodes will now appear in the
nodal list (see below; note your
numbers could be different depending
on initial meshing).

Now activate the required boundary
conditions for these nodes:

e X,y,z are translational constraints

e U,V,W are rotational constraints.

Fix these nodes; in each case 1 means
fixed, 0 means free. These are
activated by clicking on each condition
in the panel. Choose an appropriate
title for the conditions; e.g. “fixed
end”. Save the selection with Apply
and Close.

Further boundary conditions: The
problem will use 3D shell elements,
but we would like to treat this as a
pseudo 2D problem with only
deformation allowed in the x-y plane.
Therefore contrain the other ‘free’
nodes in the z direction by repeating
the above operations for the new
selected nodes. Save with Apply and
Close.

- Boundary Condition Creation/Editing =
I Mode
| D [1 @® selection € Master ¢
1 =
k| (¢ T - sekctionType
= (® selection
1 BOUNC / EntyTy
T 1 7 IDNOD X 7 Z [1] ] IFRA © Del selecton @ Nod
1 || L BOUNC 0 1 1 1 1 1 0
‘ : T h - d = = Ofiterstiod =] Ok
|y = RANE BOURC = O Del Fiter sNod Qpart
[ 1 J END O Negative O cerp
T
! &
Node L Remove
| A = =
1 Range Input/Edit
1
1 Advanced [ Auto Create  [] visible Highlight [“]show | Reset | |5 Apply| Close
i e | [ ][ |
Boundary Condition Creation/Editing
Mode
m: |1 @ selecti
Il )
s 5
+ v - Selection
] ) = @ selectior
4111110 BOUNC /
7 IDNOD X Y z u v v IFRA O pel seler
{111 L BOUNC | 0 1 1 1 1 1 1 ]
L TITLE O Filter >N
) HAME BOUNC | >1 © el Filter
i) L3P 155 156 157 168 159 160 O Negative
END
[ Mode
3 3
Advanced [ Auto create [ visible Highlight Show | Reset | [ Apply| | Close
i ——— [ 7)=]
vode
o [2 ® selection  Master Selection
EING -
sounc / - @ selecton Entity Type
2l [ Y z U v W FRA O el seecton Ond Qarp
L BouNC S [ 1 0 [ ) o Ontenod =] Oz Os
VAME e O belFiter>tiod Orat Osen
(2] Oiegatve Oowp
X] s
Advanced Ovsble [Mtighight [Flshow | Reset | [ Apply| ck
@IM:E.TLf __ __ oo T
HYEEEEEEEEEEE e
Wi U VYN A [ N N S N A A A N N A [ I S IS S AN N N S N N
M
{90215 A O
o L L L
"k KT " Y A S RN NN SR N S SN S S S G S S S S S S S S S
o | L L PP
G LIS R Y S T S U S S S S " S S S S S——" S S S S
NN EEEEEEEEEEEEEN
R S S
e a

Visualisation (on/off) of entities

In the explorer panel (left tree
directory) it is possible to edit entities
and to switch on/off their visualisation.

Click on the solid blue circles to switch
off visialisation of the new boundary
conditions.

= Initial Vielocity (IV)

{7 Acceleration Field (AF)
{7 Damping (DF)
E1-{=-Displacement BC (DBC) (2

.
(= 3B BC (BC)
{7 Body Force (BFC)

{7 Concentrated Load (CL)

e Praceira Foma iIPEV

4

11}

1

1

1)
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Loading conditions (at the opposite free
end)

The aim now is to apply negative (y) loading
at the free end.

Click on the tabs Crash > Loads >
Concentrated Loads to get the panel to
assign nodal loads. Use the left mouse key to
drag a box over all the nodes at the right end
(plus x direction of cantilever) and click the
Green Arrow to assign these. The selected
nodes will now appear in the nodal list. Give
the nodal loads a suitable title; e.g “load 5kN
per node” so it can be easily identified in the
PAM-CRASH dataset file.

We now assign the loads to these nodes and

a load direction. This is done using a load

curve (which can have a constant value or a

specific time history curve.

1. Click on LCUR and then New to open a
load curve panel. Click on File > New.

2. In the new panel define the load curve
function. The x-axis is time and y-axis is
applied load. Assume the load starts at
zero and increases to a constant 5kN at 5
msegc, it is held at this value to the end of
the simulation (=10 msec to be defined
later).

3. Click Assign Curve and Close

4. Some last points:

¢ The load so far defined is positive and we
would like this to be in the negative y-
direction. A convenient way is to set the
load scale factor SCAF =-1. Also, set the
load direction IDR=2 (= y direction).

e Make sure the new load curve (LCUR=1) is
assigned to this set of nodes.

e Use ILDTYP = 1 option so the load is
applied to each node (i.e. 5kN at each of
the 6 nodes giving 30kN total applied
load).

¢ Note for a constant load the CLOAD
option could be used.

Finish with Apply and Close.

Mode

Concentrated Load Creation/Editing

m: |1 ® selection o
+ | .
- Selection Type
= Selection
CONLO /. ©
7 IDNOD IDIR LCUR SCAF IFRA ISENS ILDTYP CLOAD ODE\ Selection (
E CONLO 0 1 0 1. 0 0 =
TITLE OFiterstod [ =] |
NAME load 5kN per node O Del Filter >Nod 1l
M HOD 5 6 9 L] 13 15 O Negative ¢
END
53 . . [ Node
Range Input/
[Dautocreate [Jvisble [#]Hghlight [¥]show = Reset L, Apply|| Close
[
L o
'l
v
[
[
1N
[
[N
i
o
-
Concentrated Load Creation/Editing =7
Mode
D: |1 ® selection  Master Select
gl (¥ - ] | - Sclection Type
o] I = ® selection Entity Type
2| IDNOD DR LCUR ‘ SCAF IFRA ISENS ILDTYP  CLOAD O Del Selection @ned Oc
L conLo 0 1 o 1 0 )
me * N\ V4 = Ofiter>nod @] Ose  OF
HAME load 5kH per node == © ol Fitershod Orat Os
M HoD 5 6 9 1 13 % O Negative Qo6
END
Visual Plot Editor =%
» 4
File Edit View Curves Plot
B Iehds @R
| b | Curve Name [No.Pts.|  Xisbel |  Ylabel | Color | Xmin | Xemax | Yamn | Y
Plot 1
Edt | Curves [ Markers | Furctions %ol
Selected Eurve— — —
Pret X ! Y \\\
"] 0 0
\ 20 5 | 5 Ll
3| 10 5
e —— 7
3 — e - -
7l | LS
8
2
s $
w | « 3
n
42 i
13
i v
. 7 Show
k| L
E Mk scae: [1 | Y S [T 2
X Offset: [0 ¥ Offsat |0
v Undo |
2 g
P9 Finish X-Axis
«| & Select node| = =
v| & Cick on mi AssignNoCurve| | Assign Cuve | | Save ToModel Close
3¢ 35
Concentrated Load Creation/Editing
Mode
o1 ® selection
$ -
ﬂ ¥ |~ Selection Ty
________ = (® Selection
MO/ |_—=--[-"""1"" | T TTf=--L -
7 “iDNOD  IDIR LCUR SCAF IFRA ISENS ILDTYP N CLOAD (O Del Selectic
C CONLO! N _0 2 1 . 0 0 1 ,
~THLE _Z-" O Filter >Nod
HAME load 5kl per ngle™ = = — = — = = = = = = O Del Fiter st
L3 HOD 5 6 9 n 3 15 O Negative
END
Node
”~ 4 > &

[J Auto Create [ visible  [] Highlight [#] Show | Reset L. Apply Close
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Assigning the Material and Part data

This is done using two entities which are linked

together; namely:

1. The Material data for material data such as
modulus, density and plasticity information.

2. The Part data for (geometric data such as
thickness).

Material Editor - TTTTTTTTTT T -~
11 Elemenl!r}pa‘ aligtact] [se] Tpe: [TOTELASTIC SHELL __ _ > v
1. Material data P T
Select Crash > Material Editor and then select | [wen/ A, 1
i A . IDMAT MATYP|  RHO ’ JJSINT :)SHG ISTRAT IFROZ [
the type of Material Model; in this case use @ 101 | [k awoe __ avoe et avcos  Avdos  awxos v | |10 Hetora Hma [Ty
-0 A 0 0
— ELASTIC_SHELL. Finally define the material At > coapttever e - ,
. 4 Bl — 7 N 1 W s
data Steel (E=210 kN/mm?, v=0.3 and density S T
7.8*10° kg/mm?). Save with Apply and Close. et
Remark: Make sure the units are consistent e.g.
kN, mm, msec and kg; the analysis e [t s ]
results will be in the same units.
2. Part data
This is most easily done via the Explorer panel:
1. First click on Parts and the list of parts will E;;&”‘wamm 1
open; select the required part. Press the left el [
. - . M= Node - 4 0%
mouse key and activate the Edit option; the e Barnr @ 59 o [
- Groups (GRP) ﬂ s
. £=> Optional Groups {OGRF)
parts panel will open. = tneras 0 1 =
. . . 2> Links PART | o2 o5
2. Set the shell thickness to 2mm. Click just = T | —— R T ol
below H and set this to 2 (=2mm). s wa —| e
i ) A . . i (= Rigid Body (RB) Ne_ 27
3. Finally, the material is linked to this part. Click (5 e G 10 Jﬂwl\ SR _conmcl |
. . luitiple Constraint (] ~ H NINT OFFSET NN
on IDMAT and the materials panel will open. L e
Select the required material and click OK. 2 S Losde :
. . . . b2 Added Mass (AM)
4. Give the part a sensible title (e.g. cantilever). B ooiret | [P o
g 5::;:;?%::522 )
i amping
Finish the assignment with Apply and Close. et et oM i
P bty Basefived RONNC ¢
Output results
For later studies it will be useful to have B A
details of time history information for the L o
corner node (A) and an element (e.g. B
50mm from the wall).
For the node click Crash > Output > R =
: |1 (@ selection " Mastsi
Nodal TH and select the corner node (A); & R
click on it with the left mouse key. Then e = [P B
H . . ﬁ IDHOD  ISTMOD O Del Selection @ Nod
click the Green Arrow; give a suitable Ortered 2l o=
HNAME corner node Del Filter >Nod Part
title and finish with Apply and Close. LY Onegane Goen
ﬂ [3 node |Remave

For the element repeat the process using
Crash > Output > Element TH and
selecting the required element (B).

Range Input/Edit ..
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The PAM-CRASH control data must be set

This controls the analysis and allows specific data
like the problem analysis time (in msecs in this
case), specific output information and ouput
intervals for the results.

) Cantilever_10mmModel pc W
In the Explorer panel under controls the following | 5.5 Cantiever 10mmModel pe 3
controls can be opened and edited (click on the B3 Controls {7y~~~ -~ -
control and open with the right mouse key to edit): ~= =) INPUTVERSION : 20127 >~
T R = ("3 ANALYSIS : EXPLICIT 3
1. INPUTVERSION: Set this (if necessary) to the ; El-{= Optional Contrals (2) I
latest PAM-CRASH version installed and used. .' --(_) SOLVER : CRASH p
2. ANALYSIS: Open if necessary and set this to oo O%}TLUENJT ch:::n:fern?mﬁﬂ U
EXPLICIT. N B-{=- Standard Cortrols (2) e
3. TITLE: Open and give the project a suitable \‘8 -gﬁ{l %Lq{;. }'//
tiltle (e.g. Cantilever_10mmMesh); this will E-{= Extemal References
appear on all results plots using Visual Viewer | @ - {=- Transform (TF)

and is important to help identify the analysis.

4. RUNEND: Open and set this to (TI02=10.0) for
the solution time.

Control Cards Creation/Editing

5- OCTRL: Mode
ﬂ s

Type:

a. Open and set the THPOUTPUT to POINT
with 1000. This will save 1000 points of time 2]
history information for x-y graph plots in the —

.ERF results file. & JHGURE T TTIOT = ~
X

DSYOUTPUT ASTATE 50

THPOUTPUT \M 1000
b. For DSYOUTPUT set option STATE with 50 to
give fifty plots of the deformed structure in

SHLPLOT AL "===----"7"
QUALIFY

the .ERF results file. o itoc
PRTOUTPUT CYCLE
c. In these exercises results will be saved in the OTAL STRAN SuALFY
.ERF file format. In the OCTRL panel activate CORNER, STRESS e
type 3 without compression (ICOMPRES=0) r.1Ax_EGU|UALEuT_STREssSALIFY

YESHO QUALIFY1 QUALIFYZ QUALIFY3 QU
PREFILTER — — — —

d. Save the information with Apply and Close.

QUALIFY
SPHPLOT —
QUALIFY
MPCPLOT —
QUALIF1 QUALIFZ QUALIF3
MPPOUTPUT — = e
YESHO
RBODY_MESH —
MED_OPT TSTRSB  TSTRSE
MEDSTRS —
QUALIFIER

POST_PLY_FRAME mem———
- ERFKEY ICOMPRES
ERFOUTPUT RS 3 0 P4

4

Advanced [] visible Highlight ] Show Res
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- . . = B & Control Cards Creation/Editing
Finally, special output options Brom |13 6o [ Pon & oL
B Bp ©Z =il | Type:
By default only limited node and element time e e 2
history information is stored in the ERF results file; &% & eiheson P oo/ g
. . () ANALYSIS : EXPLICIT K
for example, nodal displacements and velocities, 31+ Opfioral Coriols ) oo GREE e
8 E?J\F\FIE?AMCI?GA!?A'; KELVII IREORTRUX poun 1000
and element local stresses. ot rofberuptor | 11| (i -
H H = H H H H i EE‘S%?ET:‘“MS\IZ\) RSTOUTPUT SALIFY
A wide range of additional information is available, & RNk %] o
. . . = Bxtdnal Referepcés PRTOUTPUT CYCLE
but this must be specified. For example in the 2 Tardem (5 R ST QUALIFY
Explorer panel click on OCTRL then the right [ i) /,‘_\
mouse key and Edit. Click the tab Advanced T @ e [das 1 Dveste rgrie
B-{=- Nodes (N) (160) E——
followed by SHLTHP > ALL > OK to output all o~ o ol ST
available shell contour variables to the result files. &= s ™™ [N
L. . BH-{= Links
Finish with Apply and Close. e %
El-i= Constrairts SPHPLOT
g gg‘j ‘;1 ‘im‘)} MPCPLOT
—=sin ) or
& % | LNKPLOT
Saving the dataset (as a .pcfile)
Click on File > Export and save the dataset in the
required directory with a suitable name;
E.g. Overwrite the old Cantilever_10mmModel.pc file. 51 Eipor = [ o
Export
File Mame: | Cantilever_10mmiodel pe ~
Be careful to make sure the export directory location is Diectans: |\ sersbtony0 sekioptT mp_Training 7B
Correct_ Export Order
Aslmpoted  w || PAM-CRASH Flles [ po.ps.inc. pox] v
Export Options
Remark 1: Files save in this way have the PAM-CRASH Dvisble [ Header [2] Cortiols L] Expandrange [ Pos e
input file ASCII format and are readable. The Coreel | Eoon |

File > Save option will save the model in a
vcb internal binary format (it cannot be read
by PAM-CRASH).

Remark 2: Some other dataset formats (e.g. DYNA3D
and NASTRAN) are also possible to be saved:
See the Data type options.
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The PAM-CRASH (filename.pc) data file

INPUTUERSION 2012
The PAM-CRASH dataset (TOP) ANALYSIS EXPLICIT
) . ) SOLUER CRASH
Use a text editor to ,inspect’ the input UNIT HH Ke HS  KELUIN
file: TITLE / Cantilever_18mmMesh.pc
) OCTRL /
THPOUTPUT POINT 1000
e The top of the file should similar to EEESEEUT HLET"'TE 58
this. " [END_ocTRL
e Work slowly through the dataset and Rg'l*ﬁgw -
try to identify the parameters you END_RUNEND )
have set during the exercise. su IDHOD X v
. MODE 7 1 B. a.
¢ Do not worry if some nodes, etc., MODE 7 2 o5, -
are slightly different. NODE  / 3 250, 5a.
MODE 7 y 0. 50,
NODE 5 250. a.
NODE  $ 6 250. 10.
The PAM'CRASH dataset (BO.I-I-OM) AME cantilever beam
¢ The end of the dataset should look S 21; BLARK ﬂ'_*g ALPHA HEH
similar to this: —
¢ Note the naming scheme is fairly St
logical, for example:
o FUNCT —is a function curve (in $H IDNOD ISTHOD
this case the load curve) ;:““D / o
o CONCL - is the concentrated NAME corner node
loads data and the list of nodes Erqu 15
to which it applies su IDEL
o BOUNC - are the boundary ;HELE / ]
" . #
conditions and app“ed nodes HAME element 58mm from wall
o THNOD - are the time history ELE 105
. ) END
nodes which will be output to the |, oo oF pata

results files for x-y plotting
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Part 2: Explicit analysis of the cantilever beam

Running a PAM-CRASH analysis

e Start the simulation run from the ESI
Group Folder with the latest version
of PAM-CRASH.

¢ Select the directory and your .pc file.
It is also possible to select an SMP
(shared memory) or DMP
(distributed memory) version of the
code for parallel processing and to
select the number of processors you
would like to run. The ‘Explicit
Double Precision” version is a
recommended for training problems.

o If the dataset is good it will proceed
through the dataset initialisation
phase into the solution phase and
terminate with ‘NORMAL
TERMINATION'.

o If there are data errors the run will
stop with an abnormal termination
message. Inspect the output/results
files for errors (search for ‘ERROR’
and investigate). Correct the

dataset; preferably in VISUAL CRASH

PAM (or in the editor) and rerun the
analysis.

ESI Group
License

) PAM-OPT

Z PAM-RTM

‘@ Virtual-Performance
, 2008.0

. 20100

20110

® Visual-Environment
. 80

FLY Player

FolderMatch v3.4.5

(& PAM-CRASH 64-Bit Solvers 2011
@B pAM-MEDYSA 64-Bit Sohvers 201 =
OB pAM-NVH 64-Bit Solvers 20110
(& PAM-SHOCK 64-Bit Sohvers 2011
€ Readme Virtual-Performance 201
3_5 Uninstall Virtual-Performance 20
i@' Documentation

B¥ Solver Command prompt

4 Zuriick
[Programme/Daten durchevchen P
Select input file for PAM-CRASH/SAFE 64-Bit solver...
Suchen in: . Temp_Training j ﬁi‘ '
MName Anderungsdatum Typ ‘ Grofie
& Cantilever_10mmMeodel pc 04,06.201215:52 PC-Datei pal
Dateiname: |Canti|ever_'| OmmModel pc |:
Dateityp | PAM-CRASH/SAFE input files (*pc) |
Solver type: |F'AM-EIFEASH.-"SAFE DrP/Flatfarm-t Pl Double Precﬂ
PaM-CRASHSAFE Explicit Single Precision
Mumber of processors= |I§ FE E=plicit Double Py If
Pa-CRASHSAFE Implicit
Pat-CRASH/SAFE DMP/Platform-MP1 Single Precision
PAM-CRASHASAFE DMP/Platform-tMP| Double Precisio
PAM-CRASH/SAFE DMP/MS 4Pl Simple Precision
PAM-CRASH/SAFE DMP/MS 4Pl Double Precision
HORMAL TERMINRATION
TOTAL NUMBER OF CYCLES = 8282
BVERAGE TIME PER ZONE CYCLE = 0.9709E+02
WUMBER OF 3HELLS ELIMINATED = [i]
NUMBER OF S0LIDS ELIMINATED = i)
NUMBER OF BEAMS ELIMINATED = [i]
WUMBER OF SFHS ELIMINATED = 1]
CEU(a) ELAPSED () CPU: ELRPS%
INFUT/INITIALIZATION 1.0000E+00 1.3000E+01 1.32 34.21
INTERNAL FORCES 2.6000E+01 1.1000E+01 34.21 28.95
HODAL OPERRTICNS 2.3000E+01 8.0000E+00 30.26 21.03
OUTPUTS 2.4000E+01 &.0000E+00 31.58 15.79
CONTACTS 0.0000E+00 0.0000E+00 0.00 0.00
CONSTRAINIS (RB,BW,BC..) 2.0000E+00 0.0000E+00 2.63 0.00
KJOINT /MBS SOLVERS 0.0000E+00  0.0000E+00 0.00 0.00
RDAFTIVE MESH (STRMF) 0.0000E+00 0.0000E+00 0.00 0.00
TOIALS T.€000E+01  3.2000E+01 100.00 100.00
CPU TIME T.600E+01 (s3)
ELRPSED TIME 3.800E+01 (a3)
BATIO CPU/ELAFSED TIME 200.00 %

NORMAL. TERMINATION,EXITCO MESSAGE
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Evaluating the results (Visual Viewer)

First, we shall look at selected results of the deformed structure and some information that are
available for contour plots of the complete structure; these are stored in the .ERF file (extension
.erfh5) at selected time intevals (states). Following this we shall look at typical x-y plot information
which is stored in the same file. The time output intevals for structure deformations and contours are
different to x-y plot information and were specified in the Visual Crash PAM session.
e Variable THPOUTPUT in the PAM-CRASH dataset controls frequency of time history plot
information at selected nodes, elements, etc.
e Variable DSYOUTPUT in the PAM-CRASH dataset controls frequency deformed states and
contour information for the full structure.

MeSh |Ot I‘eSultS Bl Open : C:\Uzerls‘\tnny\Desktnp\TEmp_Training J o= - =[]
Look in: Temp_Training - > -2~
Start the Visual-Viewer program (from = e
the same location as Visual Crash PAM); D!kt e e s
. esktop . = ~lamifever limmModel. ‘-~_\ 06.
you will see that the layout of the program " _|_ Contiever 10mmModel RESULT.rfhs__ 04062
: ) ) i ™ ® Cantlever 1Onmadelsm ~ = ~ 04.06.2
and most options to visualise and - 1 Cantilever 10mmbModel.msg 04062
. Computer % Cantilever 10mmModel.pc~ 04.06.2
manipulate the part are the same as those ) P - -
H H H 4 |® Cantilever_10mmMadel. THP 04.06.2
used In VIsuaI-MeSh and VIsuaI-craSh Finene Do E’.‘gIaunch_CantilEver_lOmmMudEl.bat 04.06.2
PAM. g " BCantilever 10mmModel.R01 04.06.2
g W
LY
1. Open the results file using Open File Netwerk 4| >
and Select the _ERF ﬁle (i_e_ R Elereanes Cantilever_10mmModel_RESULT.erfhs v Open
. =P e
Cantilever_10mmModel_RESULT.erfh5). Suleby, | Flesoftper  [AAes () v] | concel |
. . R [ open as read-only Option
Note the new file extension is oommie: [ -
_RESULT.erfh5.
2. Position the structure; for example center and — &=
view in the x-y plane. o
Ka| || b [m oo ] @] sv]
Slnw@“ A I‘@Fast
States
3. Click Results > Animation Control and you e ®
. . . 1
will be able to visualise the model and use the T
39: 5
adjacent panel to examine deformations, either ik 4« | @
42:
at a certain time, or as a continuous animation. B B
jgf Goto: 51
‘4‘; | lskp: 1 =
49: £
50 : 5.800906 || | Count: 51

51:9.999694 -

Use the Speed Control option to change the
viewing speed in the animation option.

Ampify

All: | 1.0 X: [ L0 ¥:| 10 Z: (1.0

Static States

[ mnitial Mesh I Part Color J

Additional tabs are available for overlaying the = Eg’mm“w’“‘““ e [l
Multi States...
Initial Mesh or Simultaneous Display for I_
Reset Close

viewing selected states simultaneously. Click
Close to exit this option.
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sver 10mmModel RESULT| EL/ Contour 7 =] [ Animation Control (% ][=]
. Resubts  Sections Cur| | Contour | Ranking | Vector/Tensor | Animation
4. Click Results > Contour and under = « R . wl«[al b [ w el
F_— . Node (Banded) Node (Smeared) T
Select Entities activate — s @ e
H Contour States
Displacements_Nod_Y and Apply. B ot Do = =

[ Global Min/Max Display MinMax D

The contour distribution of nodal

Cantilever_10mi

displacement (component Y) is shown oo §| Flmme [ i ]

States to Animate...

4 L@
mecc=0.000 s NGDE 1 | || Results [Entities | Advanced

with information on max/min values. o
/ 0.000 | selectemtes... | Goto: [t
26814 NODE H skip: 1 2
DISPLACEMENTS_NOD_X 51
5229 T —
You will see various display options are T8 T osieiens Yoo
. e 10457 e Velocity X v:[10 | z[10
available and the possibility to change | . =
e R R e/ Velooty_Magritude Iritol Mest o
contour limits if required. _ 1see ket S ™
B o PART [ simultaneous Display... ™ Part Color J
N e Hourglass_Eneray_per_Part O mnstates
o -20914 Intemal_Energy_per_Part
_23 528 Reset Close 1,

This option, together with the previous

|

-26.143 import.. | [Bxpert...| [ 3¢ ] [BE][L eomy

animation control panel, allow different B 28757 Lo |,
contours for both nodal and element o

variables to be visualised at certain time 28600

states, or as an animation. 82y

L.

ser 10mmModel RESULT| H:/ Contour @ [ "% |8 | | Animation Centrol =% |[=] |
. Results  Sections Cur| | Contour | Rarking | Vector/Tensor Animation
5. In the Contour panel the entity type = B e
SHELL can be selected and, for example, g:““i“““’ e LRI T
the variable Membrane Stress First Contour e
Contour OnfOff ] Auto Display =) {}/@®

Princ. selected to plot the maximum e 2 vt e
38:7.401527

principle stress distribution for the e e ——— 55 7amss S

Membrane_Stress_First
. - - mln:rU.?ng SHELL 1 ﬂL
structure. The adjacent view is for the last | neres « s o | wesis (e [advened

State
state (=10msec). 7657 SokcEntts. el
7097 /" Lower_S_Stress_Second Princ. -~ skip: |1 -
Membrane_Stress_XX —
6.538 Membrane_Stress_YY d

— Membrane_Stress_XY

IS . Membran_Siress First Princ. J—

/" Membrane_Stress_Second Piinc
B = All:| 1.C s [ L AT : [
5418 e Membrane_Stress_Res_local XX 10 | x:[L0 | v:[10 | Z[L0

5978

- Membrane_Stress_Res_local_YY -
g Membrane_Siress_Res_local XY Sab s
lembrane_Siress_Res loca
= a—— Initial Mesh Part Col
_ 4299 ./ embrane_Stress_Res_local_Fist Prnc Bl I partGolor [_|
w7 Membrane_Stress_Res_local_Sscond P [ simitancous Dilay...| [ partcolor ||
— 373 Moment Jocal_XX.
Momert_local_YY [0 wmutistates...

3179 Momert_local_XY -

= 2619 4 » Reset Close ,

Ig 2060 Import.... | Export.. ﬂ E% Apply
. 1500 Cose |,

0.940
0.380

-0.179
-0.739
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Time history results

From the original Visual Crash PAM session two specific points of information where stored for x-y
type plots; namely, the element located on the upper surface at 50 mm from the wall and the top

corner node at the loaded end.

To collect this information click File >
Import and Plot which will open the
adjacent panel. Under Entities click
NODE and a list of sored nodal time
histories save will appear. In this case
there is only the ‘corner node’. Click
this and also the information to be
plotted Displacement_global_Y and
PLOT.

The red (oscillating) curve plotted is
the displacement time history
(component Y) for the upper corner
node. The oscillations are typical and a
consequence of the undamped
dynamic explicit FE solution method.

Using similar steps time history
information for stress (and other) variables
in selected element can be plotted.

In the Import and Plot panel activate
the Entity Type SHELL:

Membrane_Stress_Resultant_Local_
First Princ. and PLOT,

then

Membrane_Stress_Resultant_Local
Second Princ. and PLOT.

The two curves (one is nearly zero) are
plotted for these principle stresses in the
selected shell element.

- 0OX]

SECTION
0 [ THn0D comer node Dizplacement_giohal_viL1)
Import and Plot ol A
-7t Plot | Cross Plot
»p/Temp_Training/Cantilever_10mmModel RESULT.erfh5 . g
Dataset Plot Type
Qcontowr @ cuve || @xr € polar  Complex
—-14} Entity/Ordinate | LoadCase
£ Entities (1/1)
E, NODE ¥ 8l
= THNOD comer node.
=
w
221t
O ent globa
ent_global Z
ﬁ ent_globial_Mar
% velodity_v =
a o8 “ »
e 5 OuOse HE O Ow & H
omplex Data | Where to Plot | Axis Type | Advanced
=351
@ CurrentPage | @ curentwindow | O f
[ overwrite
Onenpage | O New Window @ ﬁ
_420
4 e 6 Flot Close
TIME(millisec) :
1 6 — element 50mm from wall Membrane_Stress_Res_local_First Princ.(L1)
—— element S0mm from wall Membrane_Stress_Res_local_Second Princ.(L1)
_
< 8
o
o
w
[72]
w
x
n 4

TIME(millisec)
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Part 3: Exercises in explicit analysis

3.1 Quasi-static explicit analysis and nodal damping

The oscillations of the structure observed in the previous analysis are a consequence of the explicit
integration method and the dynamic way loading is imposed over a short duration. For this simple
beam structure these oscillations can be removed using nodal damping; a full description is given in
the PAM-CRASH user and theory manuals.

Nodal damping should only be imposed once the structure is fully deformed under constant loading
and in a state of dynamic equilibrium; in this case after 5msec. It should not be imposed during the
loading phase as this will damp the loading deformations and in the case of elasto-plastic analysis may
change the plastic distribution. The formula to imposed critical nodal damping is given in the PAM-
CRASH manuals as,

NODE
|—— upperioaded node Displacement_v=ran]

where T is the period of oscillation of the frequency to be
critically damped; in this case T= 1.5 msec. Critical damping
will damp the selected frequency over one cycle.

DISPLACEMENT{mrm)

Damping is applied from 5 msec onward using two cases:

1. Critical damping q¢rit =4 n/ 1.5 = 8.38

2. 20% of critical damping q = 0.2* 8.38 = 1.68 " e
To apply nodal damping open s cestoneaing T
Mode
the adjacent panel using " s @seerton £ htrseecon
it | Y| SelectionType
CRASH > Loads > - ol -

H 1 1DHOD ADAMP  TIDAMP  TFDAMP  IDAMP ISEL TIDAMPOp ADAMPOp1 | (O Del Selection Omed O 6p
Damping. In the selection (]| [oame O mewmo gawew L 2 4 e e
type CIICk Part and then Cllck M NAME critical damping fram § msec to & msec ©) Del Fiter shiod @bt Oseg

the structure in the main a el I
on
. X] [Pt~ 91| |Remove Al Selection]
window and Update . ’ —
SElectiOI‘l to Se|eCt the fU” [visivle  []Highight [Jshow | Reset | L Apply| | Close

structure for damping. The
critical damping value is entered, together with a start and end time for damping of 5msec and 8msec
respectively. Chose a suitable title and click Apply and Close to finish.

| Export = | 7
Export
File Name: | Cantilever_10mmbdode]_CritD amping. pe L
The modified dataset is saved using File > Export in Ditectory: | Wsersfany\Desloph smp_l1ainig VB a
directory with a new file name, e.g. oot Oriy

Az lmported v | PAM-CRASH Files [po..ps..inc..pox] ¥

Cantilever_10mmModel_CritDamping.pc Export Options

[ wisible Header Controls [ ] Expandrange [~ Posfile

Cancel | Export
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Repeat the same operations using 20% of critical damping (=1.68), with all other data remaining the

same. Export the dataset as Cantilever_10mmModel_0.2CritDamping.pc

The two damping cases are run with PAM-CRASH to generate new .ERF results files:
Cantilever_10mmModel_CritDamping_RESULTS.erfh5
Cantilever_10mmModel_0.2CritDamping_RESULTS.erfh5

These results are now compared with the undamped solution for the corner node at the loaded end.
Start Visual-Viewer and open the previous undamped results file (Cantilever_10mmModel_
RESULTS.erfh5); using the previous

procedure plot the vertical displacement time 0 SEeTin —rma ‘
history (Displacement_global_Y).

A convenient method to superimpose the
damped results is to use the Chase Curve(s)
option. Click on the current time history curve
and it will change colour to black. With the
right mouse key new options will open; click
Tools and then Chase Curve(s). Using the
windows folder options the damped results
files (do one after the other) can be loaded
and automatically plotted. Note there are
options that appear to allow curve settings to
be changed, for example the colour. Y e mitise)

DISPLACEMENT(mm)
o A
= £

N
3]

_351

SECTION
0

20% damped undamped

XN
NV
. critical damped
6 8 10
TIME(millisec)

=

DISPLACEMENT(mm)
~n

[ Y
=

-35

“% 2 4 6 8 10
TIME(millisec)

The displacement time history curves for the free end corner node shows that critical nodal damping
has rapidly damped the structure within one oscillation, and that 20% has nearly managed this in the
selected time window of 5 msec to 8 msec. In both case the final quasi-static deflection of the beam is
approximately -38mm.

Remark: Generally, critical damping is not recommended as this can lead to stability problems;
instead 10% to 20% of critical damping over 2-3 oscillation is preferable. In this study the
damping was deliberately switched off after 8 msec to see if further oscillations occur, or if
stead state equilibrium has been reached; it more-or-less has.
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3.2 Mesh refinement and further analyses

In this section the 10mm FE mesh model is refined to give equivalent models having 5mm and 2.5mm
elements sizes, and a model using triangular elements. These new models will be used to study
several effects including hourglassing and solution convergence with refined meshes.

The following steps briefly outline the steps to prepare the new models.

1.

Start Visual Crash PAM and read in the 10mm meshed model (the one without nodal damping)
that we have been using.

This mesh is easily refined using the option 2D > Split and the splitting option shown below. All
elements in the model must be selected. The new mesh has four times more elements with a new
side length of 5mm. Finish with Close.

Split - 2D Bl7 =]
“ Tethod >«

| eHa ¢DACH O
~OMA& OHA O Of2,pont

[C] with Preview
Flip

Mo Stitch v Smooth

New Node ID: | 566

New Element ID: | 526

Undo

Apply | Close ‘

Check the model: The material data and control data are good; but the boundary conditions and
loading are not strictly correct (have a look) since hew generated nodes have no boundary
conditions or loads. However, the model is valid and we can it for now. Note that the total loading
is still the same as the 10mm meshed model, although poorly distributed.

Export the dataset with a new name (e.g. Cantilever_5mmModel.pc) and run it using PAM-
CRASH.

Repeat the above procedure and refine the 5mm mesh model one level further (element side length =
2.5mm); again use a new file name when exporting (e.g. Cantilever_2.5mmModel.pc).

Split - 2D = ? =]
Method

@HA OMACH O
oA OKA CL O, pont

[ with Preview

Flip

No Stitch ~ Smooth

New Node ID: | 2126

New Element ID: | 2526

Undo

Apply | Cloze |
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The two refined analysis models are run with PAM-CRASH and are now compared with the
previously analysed 10mm meshed model. Only the undamped results are used in this comparison.

SECTION
e Start Visual Viewer, open the .erfh5 results file for ° —e

the undamped 10mm meshed model. Then plot the 7
nodal displacement (Component Y) for the loaded
end corner node.

Lolobal_v(L1)
Al Y(LT)

-8

o

e Use the Chase Curves(s) method describe in the
previous section to superimpose the same
displacement time history for the 5mm and 2.5mm
meshed models; you should get the adjacent plot.

8]
=

DISPLACEMENT(mm)
&
o]

S
=)

The 10mm element gives the lowest ‘average’ end

displacement (= -38mm), whereas the 5 mm and 2.5 48
mm element mesh models both show greater average
end displacements (= -47mm). % 2 I 5 )

Titles and graph legends can be modified. Anywhere on the graph view click with the right mouse key
to open Tools and then Legends and Labels. From the new panel new labels, font sizes and colours
can be defined.

__SECTION -0 SECTION -2
cection >

0 mm me sh component displacement V)

bement

prt_global Y(L1)

o
)

(e e v——

IN)

=
N
=

Plot Type.

[
R

&
]
DISPLACEMENT(mm)

DISPLACEMENT(mm)

IS
S
IS
=)

A
o B 5 e8]
[ use color Settings ﬂ

isplay Outside
Show
Mle  [JPimay [ Secondary

-48L

=% 2 4 6 8 10 0 2 4
TIME(millisec) R TIME(mill oo |,

A close inspection of the deformed model at the restrained end, below, shows poor deformations and
local hourglassing; this has led to (incorrect) greater end point deflection.

The boundary condition nodes come from the original 10mm meshed model, so only every second
node in the 5Smm mesh and every forth node in the 2.5mm meshed model is restrained. This is bad
practice and all nodes should be restrained! However, it is an interesting result and the opportunity is
taken in the next section to discuss hourglassing and methods to treat it.
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3.3 Element types and hourglass control

Hourglassing is a problem of under-integration techniques used in the numerical integration of
element stiffness (or other quantities) and is especially common in ‘one point’ integration elements
used in explicit FE codes. It is a phenomena that can be easily excited in regular meshed structures,
or poor loading. A full description of hourglass theory and its control is given in the PAM-CRASH
theory manual.

Essentially, hourglass modes are certain element deformation modes that erroneously predict zero
deformation energy at the element integration point(s). For one point under integrated elements this
point is at the centre of the element. Three methods could be used here to control, or eliminate
hourglassing:

1. Fully constrain all nodes at the boundary; this would be the best modelling approach.

2. Use a different element type that does not have hourglass modes, for example 'fully’ or
‘reduced’ integrated elements, or triangular elements.

3. Apply increased hourglass control parameters (this rarely is very effective).

For this study to control hourglassing the 5mm mesh model with the poor end restraints is used. Also,
for easier comparison of solutions use the previous parameters for 20% critical damping for a quasi-
static solution. Open the file Cantilever_5mmModel.pc, add damping and export as,

Cantilever_5mmModel_ 0.2CritDamping.pc

Method 1: Using the Hughes-Tezduyar (reduced integration) element

The Belytchko-Tsay shell element is

Material Editor =[5 ==
the default PAM-CRASH shell element 10:1 Element Type: | BliStuct] )| Tope: | 101-ELASTIC SHELL v
and was used in all previous studies. e hoose Dotabee..._| | 2]
It is CPU efficient, but is under- M“E”’ G o S o e O s et Al
integrated and can suffer hourglass R AT S Pt egeaion for ik sty | Youngis Modue | e
problems. Instead the Hughes- e e Y ens G

210. 03 4: Incompatible mode element for 8-nodes solid
BLANK KSI Fo
0 o 6: fully integrated and curved formualtion Batoz (Q4gama)

Tezduyar element, which uses a
reduced (2*2) integration scheme, is
analysed. This is activated via the
Material panel in Visual-Crash PAM =1 Lot [l sy =
(Shell element type 1 under the ISINT parameter). Make this change to Cantilever_SmmModel_
0.2CritDamping.pc, export the file under a new suitable name and run with PAM-CRASH.

P » < »

NODE

= upper loaded node Displacement_Y=mm:=

Analysis results show that hourglass modes
are eliminated and deflections (=-38.5
mm) compares well with the previous
10mm mesh case using the Belytchko-Tsay
element.

DISPLACEMENT(mm)

TIME(millisec)
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Method 2: Using triangle elements

The Belytschko-Tsay element is used (set parameter ISINT in the material cards) and the 5mm mesh
model Cantilever_SmmModel_ 0.2CritDamping.pc is modified to have triangle elements. This is
done using the Split option in Visual Crash PAM. Export the file under a new suitable name and run
with PAM-CRASH.

The maximum deflection is about -36.5mm as shown below.

NODE

e et l0aded node Displacement_Y=mm=

DISPLACEMENT(mm)

TIME(millisec)

Note in this case the poor boundary conditions have been used but there are no signs of hourglassing.
Triangle elements do not have hourglass modes. Also, it can be seen that the end deflection is slightly
less (=5%) than the quadrilateral element mesh result; this is due to this element formulation being
slightly stiffer.

Remark: Hourglassing is actually very rare in analyses and should not occur if the standard PAM-
CRASH hourglass controls are used in under-integrated elements.



Tutorials 1,2: End loaded cantilever and shell element studies

3.4 Element convergence (explicit analysis with the Hughes-

Tezduyar element)

It is expected that a ‘well behaved'’ finite element should show a convergence trend. That is, analyses
using increasingly refined meshes should tend toward a converged solution.

The following is a convergence exercise to try. Use the Hughes-Tezduyar shell element (to eliminate
hourglassing) with 20% critical damping for a quasi-static solution. Compare maximum deflection at
the corner node for the 2.5mm, 5mm and 10mm meshes.

Results for deflection:

21k

DISPLACEMENT{mm)

2ak

28k

NODE

=== upper Inaded node Displacement_¥=mm=
=—upper loaded node Displacement_Y<mms=
=——upper loaded node Displacement_Y<mm=

10mm mesh (125 elements)

5mm mesh (500 elements)

TIME(millisec)

It can be concluded that this element has a
good convergence trend and the final
deflection is about 40mm (for this element

type).

A similar study for triangle elements should
also show convergence with refined meshes,
but with slightly stiffer behaviour.

End deflection

40
39,5
39 4
38,5
38

9,75

37,5
37 4
36,5 1
36

35,5

500

1000 1500
No. elements

2000 2500

2.5mm mesh (2000 elements)
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Part 4: Implicit analysis of the cantilever beam

The following briefly shows the simple steps needed to convert a PAM-CRASH Explicit dataset to an
Implicit dataset. The changes are to the control cards only and are:

1. To specify that an Implicit analysis will be undertaken.

2. To specify that a Static analysis will be performed. In this case geometrically Linear analyses
will be performed; in the next section this is changed to geometrically Non-Linear.

3. To specify the element formulation to be used; in this case Element type 6.

There are two ways to do this, either:

Read the explicit dataset into Visual Crash PAM, make the necessary modifications outlined
below, and export the modified dataset to a suitable new name, for example for each case:

Read in Cantilever_10mmModel.pc and export to Cantilever_10mmModel_Implicit.pc

Read in Cantilever_5mmModel.pc

and export to Cantilever_5mmModel_Implicit.pc

Read in Cantilever_2.5mmModel.pc and export to Cantilever_2.5mmModel_Implicit.pc

Or

Make a copy of the datasets in advance and work with the copy. This is the safest way to do it as
there is no risk to loose, or accidentially modify the original.

1. The implicit control card

In the explorer panel under Controls the type of
analysis can be changed from EXPLICIT to
IMPLICIT. Then click Apply and Close.

Cartilever_10mmModel_Implict pc

ol

~(ANALYSIS | EXPLICT
{=- Optional Cortirais {2}

B2 Standard Controls (2)
() OCTRL/
-+{_y RUNEND/
E-(= Bdemal References
{27 Transform (TF)
= DelEm (DEM)
& Dmpew (DMP)
{2 Vanables
- Parts (F) (1)
3-(=- Nodes (N) (160
-G Elemerts (E) (125}
{2 Groups (GRP)
& Optional Groups (OGRF)
- Materials (M) (1)
3-(= Lirks
3-(=> Joirts

s (7)
-~ INPUTVERSION : 2011

)y TITLE / : Cantilever_10mm

r_10mmMode]_implct pc

I Made

ANALYSIS
VERSION
EXPLICIT.
EXPLICIT

IMPLICIT

ANALYSIS

[] visible Highlight

2. The type of implicit analysis

Contrel Cards Creation/Editing
Mode

Type: |ICTRL /

In the main window under Crash > Controls > B ¢ i}

Standard Controls look in the window Type for 2] |

ICTRL. Click this and the adjacent panel opens. In mavssTee s s

the line ANALYSIS TYPE activate STATIC and &) ””““““" e

LINEAR. Then click Apply and Close. ] | —— :
Advanced Dlvsble [ righight [Ishow | Reset | L apply| [ close

| Control Cards Creation/Editing

3. The element type Moce ——

In the main window under Crash > Controls > LS .

Standard Controls look in the window Type for ] ,_mc_:j;:n

ECTRL. Click this and the adjacent panel opens. In s s

the line SHELL FORMULATION activate type 6. s rommunon [

Then click Apply and Close. L3P .
Advanced Olveble [righignt Clshon | Reset | L Apoly| [ i




Tutorials 1,2: End loaded cantilever and shell element studies

4.1 Static linear implicit results

Use PAM-CRASH Implicit to run the three implicit cantilever beam problems; namely,
Cantilever_10mmModel_Implicit.pc
Cantilever_5mmModel_Implicit.pc
Cantilever_2.5mmModel_Implicit.pc

Results from the analysis are processed in exactly the same way as the previous explicit analyses
using Visual Viewer; all results are stored in the respective .ERF files. The following plots show
contours of deformations for the three models.

Cantilever_10mmiodel_impiicit
DISPLACEMENTS_NOD_Y(L1) 2/1000
in=-356364001 o NODE 5 i1 Cariever_| (e it FESLLT ri Cantilever_Smmbodel_implicit
=1 3336.008 a NODE 157 Cantlever | Onnodel Jnpic_RESULT €15

mModel_implicit
i

2/ 10.000000

211000

0.000+000
-24426+000
-4.884e+000
-7.3260+000

-9.768e+000
-1.221e+001
-1465e+001

-2.930e+001
-3.175e+001
-3419e+001

-3663e+001

L.

] ]

The three implicit analyses show similar results and trends to the explicit analyses with maximum y-
deflections being:

for the 10mm mesh = 36.63 mm
for the 5mm mesh = 39.22 mm
for the 2.5mm mesh =41.01 mm

Remark 1: Generally, the element shows a good convergence trend; that is, the more elements used
the more accurate is the result and the results tend to a converged value.

Remark 2 : There is slightly greater displacement indicating this element type is less stiff than the
previous element used in the explicit analyses.

Remark 3: For this case the linear implicit analysis is much faster to analyse than the explicit
analysis. This is not always the case and implicit analysis can become CPU expensive if
significant material and/or geometric nonlinearity occurs and is included in the analysis;
see the next section.
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4.2 Static geometric non-linear implicit analysis

Generally a static linear analysis will provide good results for most problems if the material is linear
and displacements are small. In this case, however, displacements are large and a close inspection of
deformations (look at the width of the beam along its length) suggests something might be wrong;
indeed the beam gets wider!

Using Visual Viewer, open the 5mm mesh linear static analysis results. The deformed width of the
beam at the loaded end can be measured using the ‘measure’ tab shown below. A new panel opens
and then click on the two point to be measured. It is seen that the beam width increases from 50mm
(undeformed) to 51.25mm which cannot be correct under this applied loading. A contour plot of nodal
displacements (x-Component) also shows strange results that the beam does not shorten in the x-
direction!

£l.¢ Visual-Viewer 8.0 - Temp_Training/Cantilever_SmmModel_Implicit_RESULT.erfh5 (mm kg millisec) = |
Applications  File Edit View Insett Resuits Sections Curves Plots Drawing InjuryReport Tools Macros Window Help L8/
3
= = = A
BB BId@C L~ || & | & S basicEntity| k |8y Basic Ent| k ok b b [Preadd B dEaB R e 5 o
Standard Views Selection Visibility -~ ity
Hen Yol -O08 . ) pEEFeE | DKADP DPHMEe——0® 2 |B
Page Resuits an
M a X n 5 OX
o = Cantilever_Smmhdodel_Implicit .
TR rom (12 Ep [ P [Gh | - - 2710.000000
El Page/Fie View &
vew: @ Ofie 7] Measure =% [=]
= %D o Distance | Angle | AreaVolume
& (F1) Page 1 Distance between 2 points
St g (V1) C:/Users Aony /Desltop/ Temp_Tra 2 Points ~ | |Elements
&g Solver : PAMCSM
@ Solution : Static_Linear [“IDistance = 51.25502mm

@ Total Number of States 2 Ot o e
[]xf = 51255 [Jox= 112728
[z = 112728  [Joy= 50

[yz=so [dpz=0

Undo

ad | | cose |

Dist = 51.25502 mm

Remark: Linear static analysis is valid for most problems involving small displacements. In this case
the derivation of the element stiffness matrix assumes a linear relationship between
element displacements and strains and other simplifications are made regarding the
interaction of element deformations and the material strains.

In effect these simplifications lead to a constant structure stiffness matrix that assumes a
linear relationship between loads and displacements. This is not valid in this analysis as
large deformations occur and a full geometric nonlinear analysis must be performed. In
this case the structure stiffness matrix is a function of the displacements and a non linear
iterative (e.g. Newton Raphson) solution is necessary.

A geometrically non-linear analysis can be activated in PAM-CRASH Implicit using the following
changes; we shall do this arbitrarily for the 5mm mesh model.
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1. Copy the 5mm mesh case Cantilever_5mmModel_Implicit.pc to a new file; e.g.
Cantilever_5mmModel_Implicit_ GNL.pc.

2. Change the “Type of Analysis”. In the Explorer window locate the existing ICTRL control card and
change the Qualify2 from LINEAR to GEOMETRIC NON LINEAR, click Apply and Close to save
the changes. Note it is still a static analysis problem.

3. Finally, nonlinear analyses are performed as a series of load increments, with iterations being
made at each load increment to an acceptable level of convergence. Information of the load steps
must be given. This is controlled by the time value defined in RUNEND (=10) and the time
increment which is set under Crash > Controls > Standard Controls and in the window Type
for TCTRL. Set parameter DT2USR=0.2. These two values mean that 50 load increments will be
made, which is a reasonable number.

4. Note that the RUNEND parameter (=10) was the duration time used for all explicit analysis work.
In the previous implicit analysis it had no meaning and was ignored.

5. Export the model to the file Cantilever_5mmModel_Implicit_GNL.pc and run the analysis with
PAM-CRASH Implicit.

Some results for the analysis are briefly presented

First, it is useful to look at a typical step in the output file. The time is specified and this increases
from 0.0 to the end time 10.0 in intervals of 0.2. The number of Newton Raphson iterations for
convergence is given together with output on solution progress for each load increment.

TIME..cveevrannansnanasnnannnns 1.0000E+01
TIME STEP.v:evvassnanassnanasss 2.0000E-01
INCREMENT.... 50
NEWION ITERATION....vevvvannnns 1

REFERENCE FORCE 5.1462E+00 (MODEL AVG. : 6.7866E+00 ON 6£5.05% ZONE)
LARGEST CURRENI RESIDUAL FORCE 3.9702E-13 (NODE : 555 DOF 1)

CURRENT RELATIVE FORCE 7.7148E-14 (THRESHOLD : 1.0000E-02) CONVERGED

EVG. MRH. FORCE 7.3342E+01 (MODEL MAX FORCE =: 9.6927E+01)
REFERENCE DISPLACEMENT : -3.4B95E-06 (NODE : 15 DOF 2)

LARGEST CURRENT DISE. CORRECTION : -3.4895E-0& (NODE : 15 DOF 2)

CURRENT RELATIVE DISPLACEMENT : .0000E+00 (THRESHOLD : 1.0000E-02)
CONVERGENCE WAS ACHIEVED DUE TO LINEAR FORCE INCREMENT

-

EEFERENCE MOMENT : 4.2228E-04 (MODEL AVG. : 5.5466E-04 ON 33.30% ZONE)
LERGEST CURRENT RESIDUAL MOMENT : -3.4694E-1E (NOLE : 551 DOF &)

CUERENT RELATIVE MOMENT : 8.2160E-15 (THRESHOLD : 1.0000E-02) CONVERGED

AVG. MRX. MOMENT : 1.359%E-02 (MODEL MAX MOMENT : 1.8109E-02)
EEFERENCE ROTRTION : -1.7653E-08 (NODE : 555 DOF &)

LARGEST CURERENT ROT. COREECTION : -1.7653E-08 (NOLDE : 555 DOF &)

CUERENT RELATIVE ROTATION : 1.0000E+00 (THRESHOLD : 1.0000E-02)

CUERENT TOTAL RESIDUAL ENERGY : 3.5687E-20

CURRENT RHS RESIDURL NORM : 3.1293E-12
CONVERGENCE WAS ACHIEVED DUE TO LINEAR MOMENT INCREMENT

NUMBER OF ITERATIONS IN INCREMENT : 1

The following contour plot shows nodal displacements for the cantilever beam. The geometric non-
linear analysis has now led to a correct prediction of structural deformations. In this case overall
deflection of the beam is similar to the linear results; however, the width is now correctly predicted to
be 49.986mm (~ 50mm)The stress distribution and x-component of displacements will also be
correct.
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Cantilever_Smmbdodel_Implicit_ GNL

DISPLACEMENTS _NOD_¥(L1)
min=-8 675 at MODE 5 in Cantilever_Smmhodel_mplict_GML_RESULT erths
max=3503 at NODE 339 in Cantilever_Smmiodel_Implicit_GNL_RESULT.erths

51/ 10.000000

3503
2691
1.879
1.067
0.256
-0.556
_ -1.388
— -2180
L 2892
-3.804
4 E18

-5427 Dist = 49.9861 mm
-6.239
-1.051
-7.863

-8.875

¥



