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Problem description
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Background information

Pre-processor, Solver and Post-processor used:

e Visual-Mesh: For generation of the geometry and meshes.

e Visual-Crash PAM: To assign control, material data, loadings, constraints and time history
(control) data.

¢ Analysis (PAM-CRASH Explicit): To perform an explicit Finite Element analysis.

e Visual-Viewer: Evaluating the results for contour plots, time histories, etc.

Prior knowledge for the exercise

It is assumed that Tutorials 1,2 and 3,4 have been worked through. In order to avoid unnecessary
repetition some explanations on use of Visual for creation of entities will be kept rather brief, whereas
some new options will be explained in more detail.

Problem description i
Unit System: mm, kg, ms

Dimensions: Composite laminate 250mm long, 20mm wide,
8.4 mm thick and 50mm starter crack.

Loading: Imposed velocity (£2mm/msec) at the free ends ;i,%,s‘“‘
of the starter crack. The other end is fully > /
. s Starter
constrained. # crack

Modeling: Two sets of composites shells represent the top
and lower halves of the laminate. These are then joined (in the uncracked portion only)
by a delamination tied interface.

Composite: Each laminate half is 4.2 mm thick and modelled using single multilayered shell
elements. The material is Biaxial NCF/Epoxy resin with 16 plies quasi-isotropic layup
[0/90/90/0]2s for each side of the starter crack.

Supplied datasets

The finite element mesh (in PAM-CRASH format) is supplied for this problem. Copy the mesh file to a
model file which will be used to build the analysis model using Visual-Crash PAM.

Copy :
DCB_Delamination_Mesh.pc to DCB_Delamination_Model.pc

This will allow the work to be repeated if the model definition phase goes wrong.
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Basic theory

A full description of the delamination models are given in the ESI PAM-CRASH™ user’s manual’.
Briefly, the delamination interface is idealised using simple interface spring elements that transmit
traction normal and shear forces between adjacent plies. Each interface is defined using ‘Tied Link’
interfaces (type 303) that will automatically generate connection spring elements from information on
the adjoining plies. The plies may be represented using either composite solid (with a separation
distance for the interface) or composite shell elements.

Essentially, the interface spring elements represent mechanical stiffness, strength and fracture energy
absorption of the interface using the idealized stress-displacement response shown below, for
example, for normal (Mode I) loading. A simple linear elastic law is assumed up to the failure stress
omax, thereafter linear damaging is activated such that at final separation &;max, the critical energy
release rate Gy of the tied interface is absorbed. PAM-CRASH will compute O&pnax from input
information Gy and omax SO that the correct energies are absorbed at full rupture. Identical arguments
are used to define shear (Mode II) response. A simple maximum normal and maximum shear stress
criteria is available which must be reached before the crack propagation criteria is active.

« ¢— Oimax (Stress limit)

& inioad/
i unI oad 5, (crack
2 "o reloal openingi)
+8Ic b) * 8Imax

Fig: The inter-ply delamination model:
a) An attached node (‘slave’ node) constrained to an element ‘master’ surface
b) Diagram of the stress-crack opening curve for Mode I loading

The values of Gi. and Gy are obtained from the standard Mode I Double Cantilever Beam (DCBZ) and
Mode II End Notched Flexure (ENF®) tests respectively. Also, coupling for mixed mode critical fracture
toughness can be determined using the Mixed Mode Bending (MMB?) test.

Mixed mode interaction is often defined via the relationship,

n n
i + & :1’
G G

Ic llc

where n=1 for linear and n>1 for nonlinear interaction. In PAM-CRASH a nonlinear interaction is
possible to define via a curve function.

! PAM-CRASH™ Users manuals, Engineering Systems International, 20 Rue Saarinen, Silic 270, 94578 Rungis-
Cedex, France. www.esi-group.com

2SO international standard DIS15024, Fibre-reinforced plastic composites — Determination of Mode | interlaminar
fracture toughness, GIC, for unidirectionally reinforced materials.

® ASTM draft standard D30.06: ‘Protocol for interlaminar fracture testing, End-Notched Flexure (ENF)’, revised
April 24, 1993.

4 Reeder J R and Crews J H, Mixed-mode bending method for delamination testing, AIAA Journal, Vol. 28, No. 7,
pp 1270-1276, 1989.



http://www.esi-group.com/
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Using VCP to make the analysis model

Start Visual-Crash PAM (VCP) and read in the mesh:

Select File > Open and open the file DCB_Delamination_Model.pc

Specify the model units system
Set the model units system by selecting Crash > I
Optional Controls > Units to open the adjacent panel, 2 o
(]
Set the units to mm, kg, ms and Kelvin. = |

Finish with Apply and Close.

TTTTTTTTT

[veble [PlHhicht [JShow | Reset Apply || Close

Defining some basic model data
For the PAM- controls the following parameters are set:

Bl DCB_Delamination_Untufted pc
B-{@ Controls {17}
O

B-{=- Optional Contrals (5)
-(_) TITLE / : DCE simulation
B+{=- Standard Controls (3)
i~~(_) RUNEND/

() OCTRL S

by TCTRL S

BH-{=- Exdtemal References

""" {= Transform (TF)

----- {=- DelEm (DEM)

----- {= Dmpew (DMP)

BH-{=- Varables

INPUT- The PAM-CRASH version being used (e.g. 2012)

VERSION

RUNEND Termination time for the analysis (=10.0 msec)

TITLE The title used that will appear on all output plots

SOLVER Use CRASH for a PAM-CRASH analysis

The nodal timestep (NODTSP) option is activated
TCTRL for the delamination interface with a minimum
timestep (DTMASS = 0.0001) specified. Beware
this adds mass and should be used carefully
e THPOUTPUT — output interval for graphical (x,y)
time history information (e.g. use POINTS =
1000 for one thousand points)

OCTRL e DSYOUTPUT - output interval for deformed
states (e.g. use INTERVAL = 0.25) for
(RUNEND=10.0)/0.25 = 40 pictures

e Parameter ERFOUTPUT - for a .erfh5 file specify
type 3 without compression (ICOMPRES=0)

ANALYSIS | Use EXPLICIT for a dynamic analysis
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Defining the composite laminate

For a laminate the following 3 entities must be
defined and linked:

1. The Ply data — Mechanical/damage data
2. The Material data — Layup and output

3. The Part data — Thickness and vector for Density
reference fibre direction

IDPLY ITYP RHO IFAIL_INP ISTRAT
PLY 1 1 1.8E-6 0 =
TITLE
1- Ply data ga\:.qE E;Tposite_data / Mechanical
. . it it
In the object explorer click on Ply (or use 125 5.

. . G012 G023 G013 NU12 KAPPA23 KAPPA13 ISHD ITRD
Crash>Materials>Composites>Ply) to open r 3 o= = =
a new composite ply panel, S S b ok, or e

0.012 0.014 0.9%

e Select a ply ID number (e.g. IDPLY = 1, or PNt 1FONaz —

use the given default) ALPHA1 _ ALPHAZ <«— | Damage

A E0ct GAMMA  EPSlfci  EPSifcu  Dfcu euck | and failure

e Select ITYP=1 for Global Ply UD composite 125 031 joos  joose  joss
e Specify the mechanical and damage Baieri bt nm o bie ame Lawrven

parameters shown adjacent and give a ERATEr2 D12 nt2 Dlau  miau  LANTYPE2

suitable title (perhaps include the composite ERATERRO  DRO. nRO LAWTYFRO

material type in this title)
¢ Finish with Apply and Close.

2. Materials data

Define a materials that can be used for each half of the DCB:

e Open a new material in the explorer panel, or via Crash > Materials > Structural

e Select type 131-Multilayered_Orth... as the material type (= multi-layered orthotropic shell)
e Set the material parameters as below (see also next page),

o Give a suitable title for the composite (e.g. type and layup)

o Materials density = 1.8e-006 kg/mm?>

o Set NOPER= 16 and ILAY=0, this opens 16 ply cards to be defined,

1. Set all thicknesses = 0.2625mm
2. Define the orientations = [0/90/90/0/0/90/90/0]; for the 16 plies
3. Link all plies to the required ply cards (parameter IDPLY)

o The other numbers are hourglass and other element default parameters (leave blank)
Below the layup data is PLYNUM and AUXVAR data which allows specify shell element
information (strains, damage, etc.,...) to be output for post processing. As required specify,

e PLYNUMx = ply number for the required output,
e AUXVARX = corresponding auxiliary variable (see next page for definitions)

Finish with Apply and Close.

3. Part data

For each half of the DCB specify:

An appropriate Part ID number.

Link the part to the composite material (parameter IDMAT).

Set the laminate thickness H=4.2 mm.

Specify a reference vector for the fibres which is used together with angles on the material
cards layup. Use IORT=0 for global frame and a vector 1,0,0.

O O O O

Finish with Apply and Close.
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PAM-CRASH materials cards:

RHO ISINT ISHG ISTRAT IFROZ
1.3E-6 0 4 0 0
AUXID3 AUXIDG AUXIDS AUXIDE avm THDID IDMPD
o 1] o o 1. o o
ILAY HGM HGW HGQ As
o 0.01 001 0.01 0.833333

1

1

1

1

1

1

1

1

1

| . .

14—  Stacking data for the laminate layup

1

1

1

1

1

1

1

1

1
GRUC_KW GRUC_WAL IFAIL BLANK ERATIO BLANK

0

IDAUX2 IDPLY3 IDAUX3 IDPLY4 IDAUX4 IDPLYS IDAUXS IDPLY6E IDAUXE
2 1 3 1 4 1 B 1 6
IDAUX10  IDPLY11 IDAUX1 IDPLY12 IDAUX12 IDPLY13 IDAUX13 IDPLY14 IDAUX14
10 1 11 1 12 1 13 1 14
IDAUX18 IDPLY19 IDAUX19 IDPLY20 IDAUX20 1DPLY21 IDAUX21 IDPLY22 IDAUX22
o o o o '] o o o o
IDAUX26 IDPLY2T IDAUX27 IDPLY2S IDAUX28 IDPLY29 IDAUX29 IDPLY30 IDAUX30
o o o o o o o o o
IDAUX34 IDPLY35 IDAUX35  IDPLY36 IDAUX3E6 IDPLY3T IDAUX3T IDPLY 33 IDAUX3S
o o o o o o o o o
IDAUX42 IDPLY43 IDAUX43 IDPLY44 IDAUX44 IDPLY45 IDAUX45  IDPLY46 IDAUX46
o 1] o o ] o o o o

MATER /
IDMAT MATYP
MATER/ 1 134
BLANK  AUXID1 AUXIDZ
0 0
TITLE
NAME composite ply
KSl Fo NOPER
o4 __ o _____[46 ___lo __
| 1DPLY THKPL ANGPL
1 0.2625 0.
1 0.2625 20.
14 0.2625 90.
P 0.2625 0.
1 0.2625 0.
11 0.2625 20.
14 0.2625 90.
1 0.2625 0.
1 0.2625 0.
11 0.2625 90.
[ 0.2625 90.
I 0.2625 0.
1 0.2625 0.
11 0.2625 90.
1 0.2625 90.
LL____D02:2% ___i 0 ___
BLANK  NMIN BLANK
0
" IDPLY1  IDAUX1 IDPLY2
o 1 1
| IDPLY9  IDAUX9 IDPLY10
1 9 1
| IDPLY7  IDAUX17 IDPLY18
, o 0 0
| IDPLY25  IDAUX25 IDPLY26
1o 0 0
| IDPLY33  IDAUX33 IDPLY34
) 0 0
| IDPLY41  IDAUX41 IDPLY42
1D 0 0

IDPLYT
1
IDPLY15
1
IDPLY23
0
IDPLY31
0
IDPLY39
0
IDPLY4T

IDAUXT
7
IDAUX15
15
IDAUXZ3
0
IDAUXI1
0
IDAUX3S
0
IDAUXAT

IDPLYS

1
IDPLY16
o
IDPLYZ24
o
IDPLY32
o
IDPLY40
o
IDPLY43

IDAUXS
]
IDAUX16
0
IDAUX24
0
IDAUX32
0
IDAUX40
0
IDAUX4E

PAM-CRASH documentation on output variables:

Notes for Material Types 130, 131, 132:

Material types 130, 131 and 132 correspond to multi-layered shell materials. The
plies can be assigned the following material types in the Ply Data Section
(parameter ITYE)

IT¥P=0: unidirectional composite bi-phase ply model, (material type 130, 131)
1: unidirectional composite global ply medel. (material type 131)
=2 isotropic elastic-plastic damaging ply model. {(material type 131)
¢p=6" fabric composite bi-phase ply model (material type 132. 131)
7. fabric composite global ply model, (material type 131)

ITY

variables saved for plots. For material types 130, 131 and 132 the
following auxiliary variables can be saved on the plot files, by specifying on Cards
8 to 13 the reference number given in the following table

Table (a): Auxiliary variables per ply for material types 130, 131 and 132

Refervence | p| POPel@3D) | piyope2(3]) | plytypeT(13D) | plytype6(li)
amber  |PY OPE

(130,131)

plype6 13)

1 an! 811 an!
2 en €21 en
3 ez a1z ez
4 £33 £13 £33
5 €13 &3 €13
o o (5311 an
7 Gn Gz G2
8 o1 on o
9 o1 o feeH]
10 O3 [t} T3
11 d (total) diz (shear) | d (total)
12 df (shear) dup (fiber 1) [ g (shear)
U d'lc (volume) daz (fiber 2) dvt\- (volume)
4 c Dgplastic G (fiber 1)
15 d : B d (fiber 1)
16 " (fiber 2)
17 ¢ (fiber 2)
18
19
20

SIVINALYIN
I713HS

Output information
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The Tied delamination interface

Entities to be linked:

1. Material data for delamination
2. Part data for the thickness/contact
3. Tied data defining which parts are connected

Material cards T
IDMAT MATYP RHO
Open the Crash/Material Editor |:iix  iwor  avse  avxos
Select the 303 Slink ... interface | =~ e '
model and specify a unique ID SOMPL__ SLPACm. SLANG EABEN
number, or use the selected default |7~ ™
Specify the data shown adjacent. i S

Part cards

SIGMApr  GAMMApr EFRAC1  EFRAC2

Fracture energies: Set Mode I and |02 jooo: 000017100015

Neycle IFUNGcont

Mode II to 470)/m? and 1500J/m?. [

ISINT ISHG ISTRAT  IFROZ

i 2 o

AUXID4  AUXIDE  AUXIDE QUM THDID
a 0 o o

IDELBEND DAMRATE TLSTIF

STRAT2  Nfilt
0.
SIGMAst GAMMAst NFEQD
0.002 0.003 100.

IDMPD
1}

Failure stresses: Typical starting values for ‘uncracked’ composites are 20N/mm? and 30N/mm? for
Modes I and II respectively. The propagation stresses are usually assumed to be 10-30% of these
values (NB an exact value is unimportant since it is the energies that control delamination). Since

the DCB tests is ‘pre-cracked’ we can assume,

Mode I - Propagation stress = Starting stress = 0.1 * 20N/mm? = 0.002 kN/mm?
Mode II - Propagation stress = Starting stress = 0.1 * 30N/mm? = 0.003 kN/mm?

Use IDEABEN =4 and the damping/filtering values shown. IDOF=0 ties all degrees of freedom

Finish with Apply and Close

Open the Crash > Parts > Part creation ™’
to generate a parts entity for this interface i
Specify in the ATYPE box TIED o
Use a thickness for the contact 4.2mm anda |42

RDIST
search thickness slightly larger (e.g. 4.3mm) |43

PART |

IDPRT
56
TITLE

ATYPE IDMAT IDVAMAT IDTHMAT IDPMAT

TIED 56 0 0

delamination plies 1-2

TSCALF

EPSINI

BLANK

Assign a title and link this to the END_PART

COULFRIC

INEXT
a

0

corresponding material
Finish with Apply and Close

Tied cards
Open the Crash > Links > Tied to 4
generate the interface 7]
Specify a unique ID number (or use ]|
the default), a suitable title and link o
this to the Parts cards via parameter =
IDPRT

Slave nodes - select the nodes (all

1DEL IDPRT
1 56
TITLE

plies 12

261427 193:388
7

2

>

[Jvisble [#]Highight [Show | Reset | |Is Apply| | Close

(%) Slave Selection
Selection Type
(®) Selection
(O Del Selection
OFitersiod =]
(O Del Filter >Nod
O Negative

Range Inpyf

except ca. 50mm at the free end by
dragging a box over the nodes
Master elements — select the top
composite ply (part)

Finish with Apply and Close
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Finishing the model

Velocity loading for the DCB loading tabs

For all nodes along the upper loading edge a positive (upward +z) velocity is applied via a velocity
time history. For those on the lower edge the same velocity time history is applied in the downward
(-z) direction.

For the upper set of nodes:

1. Use Crash > Loads > 3D BC and then select type VELBC for velocity loading.

2. Define a curve function for IFUN3 (= dir. z) having a velocity that increases from Omm/msec to
2mm/msec at 1msec. Then hold the velocity constant to 20msec.

3. Assign this curve and select the nodes.

Use a SCALE3 = 1 for +z loading.

5. Finish with Apply and Close.

>

For the lower set of nodes repeat the same operations. Use the same velocity function, but this time
set SCALE3 = -1 to reverse the velocity direction.

Boundary conditions for the free end
Use Crash > Loads > Displacement BC to fix 2 or 3 rows of nodes at the free (unloaded) end
with displacement boundary conditions 111111.

Output information

1. Nodal displacement time histories: Use the option Crash > OutPut > Nodal TH to identify and
store one node from each of the loading points.

2. Section force time histories: Use the option Crash > OutPut > Section Force with Type
SECTION to define and define section cuts close to the
upper and lower loading points. For each section a line
of nodes are selected as SLAVES, and a line of attached
elements are selected as MASTERS.

This information allows the resistance force to crack
opening to be monitored and possibly compared to test
measurements.

Save (update) the dataset (DCB_Delamination_Model.pc) using the Export option.
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Running the model and investigating results

The PAM-CRASH dataset (DCB_Delamination.pc) is run; then open the results file,
DCB_Delamination_Model_RESULT.erfh5

in a new Visual Viewer session.

Deformed state results

1. Click Results > Animation Control to visualise the model and use the control panel to examine
deformations (either at a certain time, or as a continuous animation).

2. Click Results > Contour and under Entity types activate SURFACELINK and type TIED_Damage
to visualise damage contours at the delamination interface. Note that other visualisation options
are available. The evolution of contour damage can be seen at specific states (via the Results >
Animation Control), or animated.

PAM-SOLID Simulation =B
34 1 8.250087

_ | | mep_psmagery
S e FACELDIK 632 i DCH_Delaminston_RESULT erfhs
max=) 57 of SURFACELPI 775 in DCB_Delaminabion, RESLLT erihS

0997

0931

OMode (anded) () Node (Smered)

® Bement 0.798
Contour

[ contowr on/off [ Auto Display

[ Giobal MM [] Display MinfMax ID

[ show vectors Transfuem...

Results |Entives | Advanced

Select Enttes.

B NODE

B SURFACELINK

J ISR TIED_Damage

{——— TIED_Global_Foree X
TIED_Gobal_Foros_Y

hekly [~ TIED_Giobal_Momert Y

M1 | %10 | w 210 | TIED_Gobal_Momert 2

|’ 7" TIED_Global_Momerd_Magritude
Statc States

[ trvtiad Mesh I 7=

TIED_irtemal_Energy
] -~ TIED_Maimal_Energy over_Tenw
@ SHELL

O mumnecuspugiy..| [ portcotr |_|

[ it States.
inport... | Expart...| X & gy

Reset Clse. |

SECHIUN

Time history results

Start time history contour plotting using File > If“‘.,;‘ ‘I‘Jﬁq.‘]l ) N S

Import and Plot ‘,m-“ M I M I ST

In the panel that appears activate, :“ J ' \L IL."k"lfg e

. SECTION in the Entities e i 3 A
. The required sections to be plotted wy | o LAY
. Section_Force_Magnitude ;"' — == e

. Click PLOT mf ==

TIME(millisec)

The green (oscillating) section force time history curve should appear giving a maximum force of
about 0.18kN. This information can be passed through a filter if required.

The behaviour can also be smoothed by modifying the materials input parameters using lower
propagation stress values or more filtering. Alternatively, use a finer mesh or slower velocity loading.
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ﬂ Opening force

To create a plot of opening force (at the section) versus

total opening displacement proceed as follows: =
Total opening

displacement E

~

1 DO a Cross pIot Of nodal 0.21 — Cross_lower adherend Secllonforcej(iﬂ
displacement versus opening 018
force (both in direction z for the
lower DCB arm). The reference 015
directions may be unfortunate
giving some information as g0.12
negative. If necessary this can . ]
- [ G| Oupee=f] O || @&
be modified as shown below. e e || 20.08
© urentpege: ._,;e:;l\ﬂ":l:t off
O | Ot O 0.06
==
0.03]
% a8 BT - - K 3
DISPLACEMENT(mm) -
2. W|th the Ieft mouse key CI'Ck on :: | o | Funcirs [lniry — 0.21 —AL)-;S-:a\e7C|'(;ss:i;:.\-el'a:‘!he\&miS&CHO\LFO\W,Z-T\:W:‘-K

the curve and it will appear
black. Then click the right mouse = ,‘
key to open an options panel | & 0 EE——

0.18}

Deranese Funnons Asatn S 0.15]
and activate  Tools > | ESh—
Functions... M o
w
The Scale and Offset option is | - i g
selected to scale displacements = .. =i
by (-2) to obtain total positive e g | 008
opening displacement for both ==
upper and lower DCB arms. 003
0
0 6 12 18 24 30 36 42
DISPLACEMENT(mm) )
) S‘:;.-: it [ Comatorn | rceorm [irery : 0.24r _%bS?'z‘a‘e Cre >5~4:|u-.x-<-r\¢d\:|::1d Section_Force_Z(L1) =
3. The FIIteI‘S Option With, for [— CFC 1000_AbsScale_Cross_lower adherend Section_Force_Z(L1)

example, a CFC1000 filter allows 7
high frequency information to be | e - —

filtered as shown by the new (Eiijmss - _

superimposed  green  curve. = - | P
Activate the tab ‘same plot’ to . g
superimpose the two curves. )2

-D‘Guo

6 12 18 24 30 36 42
DISPLACEMENT{mm)
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Checking the results

The opened (+ damaged) crack length and specimen width can be estimated to compute the total
cracked area. This area multiplied by the Mode I fracture toughness (Gic = 0.00047 J/mm?) gives the
total delamination energy absorbed. This energy should approximately correspond to the PAM-CRASH
computed value (= 1.54 J). This value is found from either the output listing (see the energies per
material near the end of the .out file), or from a time history plot of internal energy for the
delamination interface (Part 56). Both are reproduced below.

From the output listing: Internal energy for delamination interface (Part 56)

INTEENAL INTERNAL INTERNAL TRANSTL.
PART ID ENERGY 1 ENERGY 2 ENER TOT KIN. ENER X¥-MOMENT Y-MOMENT Z-MOMENT
1 6.1%E-01 1.1%E-04 &.18E-01 2.44E-02 -2.13E-03 1.98E-04 -3.35E-02
2 _&.19E-01 1.19E-04 6.19E-01 2.44E-02 -2.13E-03 1.98E-04 3.35E-02
56 1.54E+00 )0.00E+00 1.54E+00 0.00E+00 O.00E+00 0.00E+00 O.00E+00

From time history plot: Internal energy plot of delamination interface (Part 56)

Tmport and Plot PR X} 18 SECTION - Ox
— : |—Sﬁf‘rh=laminamn plies 1-2 Internal_Energy_per_Part(L1)
taset Plot Type - |
1.5
1.2
E
E
=
-
Fs] T . Ow & So09
Chese (4]
["4
w
=
w
0.6

ot e 03

0 2 4 6 8 10
TIME(millisec)




