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Background information 
 

Pre-processor, Solver and Post-processor used: 

• Visual-Mesh: For generation of the geometry and meshes. 

• Visual-Crash PAM: To assign control, material data, loadings, constraints and time history 

(control) data. 

• Analysis (PAM-CRASH Explicit): To perform an explicit Finite Element analysis. 

• Visual-Viewer: Evaluating the results for contour plots, deformations, etc. 

 

Prior knowledge for the exercise 

It is assumed that Exercise 1 (Elastic loading of a cantilever beam) has been worked through. In order 
to avoid unnecessary repetition some explanations on the use of Visual for meshing and creation of 

the analysis model will be kept rather brief; whereas new options will be explained in more detail. 

Problem data and description 

Units:          kN, mm, kg, ms 

Description: Plate 200mm*100mm, thickness 2mm with a central hole 

of diameter 20mm. 

Loading:      Imposed total load = 20 kN (full model) with simple 

support at the base. 

Material:      Steel (E=210 kN/mm2 (GPa), ν=0.3 and density 7.8*10-6 

kg/mm3). For plasticity use a yield stress 190 MPa and a 

constant plastic modulus 0.2 GPa.                     
 

Supplied datasets 

No datasets or meshes are needed for this problem; the meshes will be generated in the exercise.  

It is recommended that you use the following names for the PAM-CRASH input and results files:  

For the elastic problem             HoleInPlate_Elastic.pc  

For the plastic problem             HoleInPlate_Plastic.pc 

In each case completed PAM-CRASH datasets are available in case you get into trouble. 

Background information: Solution methods and geometry 

Implicit versus explicit analysis: The PAM-CRASH code is a general purpose three dimensional (3D) 

code for implicit and explicit FE analysis. This exercise performs implicit and explicit analyses of a 

simple two dimensional (2D) structure with applied force loading. 

 
Explicit analysis treats the structure as a dynamic problem and solves dynamic equations of motion in 

the time domain; it is especially efficient to solve crash, impact and similar dynamic problems, 
particularly if material non-linearity (plasticity..), large deformations or contact occur. For explicit 

analysis you will find all nodal and element quantities given with respect to time.  

 
Implicit analysis (usually) assembles the structure stiffness matrix to solve static loading problems that 

are independent of time. Material non-linearity, large deformations and contact are possible with non-
linear solution methods. This exercise will include an implicit non-linear material analysis.  

 

Geometry: The PAM-CRASH code is usually only applied to 3D structures; there are no special 
capabilities for 1D or 2D geometries. For this exercise the 2D plate is analysed using shell elements 

with appropriate loading and boundary conditions to make it a valid 2D problem. 
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Part 1: Using VCP to construct the models 
 

Preparing the mesh (Visual Mesh) 
 

Start the Visual Crash Program (VCP) and under the 

Applications tab select the Mesh option.  

This will activate the meshing module (Visual Mesh) of 

the VCP program which is dedicated to generating finite 

element meshes. 

 

Select the option New file then specify the model unit 

system: 

• Set Source Units to mm, kg, millisec, kelvin 

• The target units will be the same 

• Click OK 

This specifies the unit systems (kN, mm, kg, msec). A units 

conversion to a different system could be made if needed; 

we use the same for both. 

  

Alternatively, an old or partially completed model could be 

read in for further working using Open File and specifying 

the name of the file. 

Meshing procedures and option for the plate with a central hole 

The usually approach to mesh a plate with a hole would be to define key points in x,y,z coordinates to 

which lines and arcs (for the hole) are assigned. From this surfaces are defined and meshed. Usually 

some planning is required to make sure a sensible mesh is constructed with more elements around 

the hole, where the stress gradients are greatest. 

 

In Visual mesh there is a special option to automatically mesh a hole in a plate and we shall take 

advantage of this. The meshing procedures are: 

• First create the plate with a suitable regular mesh (ignoring the hole). 

• Then create the central hole and modify the mesh (there are special options for this). 

 

Either the full plate with the central hole can be analysed, or advantage can be made of problem 

symmetry to reduce computation costs. Taking advantage of symmetry may be less important today 

with the high speed of modern computers; however, for large problems and parametric/optimisation 

studies, where many analyses may be needed, it can still be a very useful option. We shall analyse 

both the full and quarter symmetry models in this exercise. 
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x 
y 
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(0, 0) 

 

Meshing the plate (without hole) 

The plate has four corner points that must first 

be defined. It is arbitarily chosen that the model 

lies in the x-y plane with one corner at the 

origin (x=0, y=0) and the other points having 

the coordinates shown; (use z=0 for all points).  

 

The four corner nodes are defined using the 

Node > By XYZ, Locate… panel in which the 

coordinates for each point are entered and the 

Apply tab is clicked. The default ID numbers 

are used. For the four nodes use a z=0  

coordinate value. Note that the node ID 

numbers and their sequence are not important 

to the exercise. 

 
 

Positioning and viewing options:  

Important options are available in the 

main (top) panel to position, center, 

zoom (in and out) and gererally vary 

viewing of the model. 

1. Click the axis tab and with the ‘left’ 

mouse key to open options to 

position the model in the x,y,z or 

perspective (isometric) frame. 

2. Click the viewing tab with the ‘left’ 

mouse key to open options to 

zoom in/out and generally position 

the model.  

Spend some time to review these 

options, they are important.  

 

  

(1) 
(2) 
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Generating the mesh surface 

• Position the model into a convenient view (e.g. using the 

XY tab and Center tab) so it  appears in the center of 

the screen (see previous information). 

 

• Activate the 2D > 3/4 Point Mesh tabs with the 4 

point polygon option. Then click on the four corner 

nodes in sequence (clockwise or anti-clockwise). On 

clicking the last node the surface is generated as shown. 

 

Generating the plate mesh  

Click on the Mesh tab and a new panel opens to control 

details of the mesh to be generated.  

Element sizes, grading and connection options (stitching) 

to possible adjacent meshes can be defined and 

controlled.  

specify a 5mm element size and click the Create Mesh 

tab. The mesh will appear, accept this with the OK. 

 

Generating the mesh with hole (Full model) 

Click on the 2D > Hole on 2D Mesh tabs and a new 

panel opens to control details for generating the hole in 

the plate.  

Deactivate the Auto-Compute tab and specify a hole 

diameter of 20 mm with 8 rings to be meshed having a 

‘linear’ bias of 4 (the outer element lengths are 4 times 

the inner ones). In this case the ring width is 30mm and 

60 elements are specified in the circumferential direction. 

In addition VISUAL will ask you to select a node on the 

plate to which the hole center is located (use the left 

mouse key to select the plate center node). Click tab 

Preview to visualise the mesh. If this looks suitable click 

Apply and Close to accept it. 

Remarks:  

• The new mesh can be generated and cancelled untill 

you are satisfied with the results. 

• Try to generate something that has sensible mesh 

grading bearing in mind the likely stress gradients of 

the loaded problem. 
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• Visual may have trouble to fit a meshed hole to the 

base plate mesh and not all combinations are 

feasible. Some experimentation of the input data may 

be needed before the mesh is generated. 

Saving the Full model (mesh only) 

This now completes meshing of the full model with Visual Mesh. Save the data with File > Export 

to a suitable folder with a suitable name (e.g. HoleInPlate_FullMesh.pc). Finally exit Visual Mesh. 

The next steps look at modifying this model for quarter symmetry and mesh refinement. 
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Preparing the ‘coarse’ quarter model mesh 
 

Creating the quarter symmetry model 

Probably the safest is to make a copy of the full model 

just created to HoleInPlate_QuarterMesh.pc. 

Then start a new session of Visual Mesh in which the 

new dataset is read in for modification. Start Visual 

Mesh and use Open File then select the dataset 

HoleInPlate_QuarterMesh.pc to read it in. 

Center the model in the x-y plane and visualise using 

the wireframe option to get the adjacent view.  

First elements outside the required quarter model are 

eliminated. The following steps are done: 

1. Activate the selection option “Element – By – 

Element” in the top control panel. 

2. Carefully draw boxes A and B over the required 

elements to be eliminated (drag the depressed left 

mouse key), then press the right mouse key and 

activate Tools > Delete; confirm with Yes. In 

practice this may be more easily done by repeating 

the procedure several times with smaller boxes and 

zooming into areas for better selection. 

3. The aim is to delete all elements to the left of the 

line L1 (x=50) and below Line L2 (y=100). In the 

next step the irregular cut planes will be 

repositioned and straightened to lie on the required 

symmetry planes L1 and L2. (Note: this may not be 

the best way to do this, but it does demonstrate 

some useful options! ) 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

L2 

Box 

A 
Box 

B 
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B 

y 

x 

L1 
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Finding nodal (and other) properties 

First make sure the selection option is active (e.g. 

Node-By-Node) in the top panel. Then click on the 

required node and it will be highlighted.  

 

Coordinate information for the node will appear in the 

lower panel.  

 

 

Alternatively, click the right mouse key and then 

Tools > Properties to open a new panel with the 

required nodal information will then appear. 

 

 

 

 

Similar operation are followed to get other information 

such as element numbers and properties. 

 

 
 
 

 

Adjusting nodal coordinates (1/2) 

Using the above operations it will be found that some of 

the key corner nodes  do nor have the correct 

coordinates due to the automated meshing operations. 

The following table gives the required co-ordinates: 

 

Point X Y Z 

A 50 110 0 

B 60 100 0 

C 100 100 0 

D 100 200 0 

E 50 200 0 

 

The following operations will adjust nodal cordinates if 

necessary. 

 

 

 

A 

B 
C 

D E 
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Adjusting nodal coordinates (2/2) 

 

1. The option Node >  Move (Correct 2D/3D 

Element Quality..) is used to adjust any corner 

nodes (A through E) that may be necessary. Use the 

options to check the nodal coordinates; if changes 

are needed enter the new valuse and click Close to 

modify them. 

 

 

 

 

2. Next the nodes between B-C and A-E need to be 

aligned. Use the option Node > Align tabs and 

activate the 2 Pt. Line option. For A-E alignment 

click on the first extremity node (A) and then the last 

extremity node (E), then click on the nodes to be 

alligned. A box can also be draged over the 

intermediate nodes. Click Apply and Close to 

impose the nodal coordinate changes. 

 

3. Repeat this procedure for the nodes at B and C 

with the intermediate nodes between B-C. The 

upper and right most lines should not need 

adjustments. 

 

Possible problems 

Beware that generated meshes may vary depending on the 

automated meshing process. In this case the generated mesh 

and modifications made have created a ‘bad’ quadrilateral 

element with two sides being parellel (X)! This would not be 

accepted by PAM-CRASH. We shall elimiate it and replace it 

with a proper triangle. 

Activate Element-By-Element selection in the top panel, 

click on the element (X) and delete it with the (Entf/Del) key. 

Be careful that only this element is highlighted for deletion. 

With option 2D > 3/4 Point mesh and option 3 Point 

Polygon a proper triangular element can be created by clicking the three corner nodes in sequence. 

Then click Mesh to open a meshing panel; use a large element size (e.g.10mm) so only one element 

is created and make sure the part ID is set to that of the other elements (Part ID = 1), so it gets the 

same number. 

 

 

 

 

X 
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Saving the quarter model (mesh only) 

This now completes meshing of the quarter model with 

Visual Mesh. Save the data with File > Export to a 

suitable folder using a suitable name (e.g. the original 

name HoleInPlate_QuarterMesh.pc).  

Then exit Visual Mesh. 
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Preparing ‘refined’ version of the quarter model mesh 
 

Again, probably the safest is to make a copy of the 

quater model just created to 

HoleInPlate_RefinedQuarterMesh.pc. 

Then start a new session of Visual Mesh in which 

the new dataset is read in for modification. Start 

Visual Mesh and use File > Open then select the 

new dataset,  

HoleInPlate_RefinedQuarterMesh.pc  

and read it in. 

 

Remeshing the transition zone and refinement areas 

The refirned model is to have mesh refinement in the lower half of 

the model for better prediction of stress and strain distributions 

around the hole.  

1. For this the 2D > Split option is used. First a line of 

elements for the mesh transition are remeshed using the 

option . The adjacent picture shows the line of 

transition elements that have been introduced (chose a 

similar line).  

The element to be remeshed is first selected with the left 

mouse key and then the corner node for the diagonal 

intersect is selected, again with the left mouse key. Note 

carefully the sequence to make sure there are no free 

nodes (except on the lower face where additional 

remeshing is made in the next step). If the remeshing is 

wrong select Undo before proceeding; otherwise continue 

the remeshing. 

 

 

2. Finally the 2D > Split tabs are selected with the 

remeshing option shown to split quadrilaterals and 

triangles. A box is drawn with the left mouse key over the 

elements to be refined and the new mesh is generated; 

accept with Close. 
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Combining the mesh 

In the mesh refinement process duplicated nodes 

have been produced at the boundaries where new 

elements have been created. These duplicated nodes 

must be merged and removed.  

Click Checks > Coincident Nodes and the option 

Check. This gives a view showing all duplicated 

nodes in the model (a suitable Max Gap has to be 

selected if the default is inappropriate). These 

duplicated nodes are merged with the Fuse All tab. 

Click Apply and Close to finish. 

If the Coincident nodes Check option is retried a 

view of the model showing only the outer free edges 

should be drawn.  

Saving the refined quarter model (mesh only) 

This now completes re-meshing of the refined 

quarter model with Visual Mesh. Save the data with 

File > Export to a suitable folder using a suitable 

name; e.g. overwrite the existing file,  

       HoleInPlate_RefinedQuarterMesh.pc  

 

Then exit Visual Mesh. 
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Defining the model data (Visual-Crash PAM): Some general 
comments  
 

Preparing the model(s) for analysis  

 

Full model: 

• Application of boundary conditions on the lower face. 

• Application of loading on the upper face. 

• Application of part (geometric) and material data for 

elastic and elasto-plastic solutions. 

• Application of the PAM-CRASH control data. 

 

Quarter (symmetry) models: 

The same steps are followed as for the full model, except that 

specific boundary conditions must be assigned on the (x) and 

(y) symmetry planes to impose necessary symmetry. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Starting the Visual-Crash PAM work  

The three meshed models (Full, quarter and refined quarter models) created so far will be modified 

for analysis. First elastic materials analyses will be undertaken and later these datasets will be copied 

and used for plastic analysis. 

The safest way is to make copies of the three meshes and work with the new copies. This will allow 

you to go back and start again with a new copy if things go wrong! 

Copy:  

HoleInPlate_FullMesh.pc     

to   HoleInPlate_FullModel_Elastic.pc           for elastic analysis 
 

HoleInPlate_QuarterMesh.pc     

to   HoleInPlate_QuarterModel_Elastic.pc     for elastic analysis 
 

HoleInPlate_RefinedQuarterMesh.pc     
to   HoleInPlate_RefinedQuarterModel_Elastic.pc     for elastic analysis 

 

 

Loaded end 

Restrained end 

Full model 

Quarter model 

Refined quarter 

model 
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Preparing the full analysis model: Elastic analysis 
 

Starting the Visual-Crash PAM work 

Start Visual Crash PAM and open the copied model file using 

Open File 

 

Use the copied dataset from the previous section, 

 

       HoleInPlate_FullModel_Elastic.pc 

 

Positioning and centering of the model  

Use the x-y and centering tabs to conveniently 

position the model. This will make assignment of 

the bounday constraints, loadings and other data 

easier.  

 

Also, in this case visualisation and assignment of 

data is easier if the ‘wireframe’ visualisation option 

is activated in the top panel. 

 

 

Boundary conditions  

Fixing the constrained end 

Click on the tabs Crash > Loads > Displacement 

BC to get the panel to assign nodes and conditions. 

Use the left mouse key to draw a box over all the 

nodes on the lower face, then click the Green Arrow 

and the selected nodes will now appear in the list.  

 

Activate the required boundary conditions for these 

nodes (1=fixed, 0=free), in this case fix:  

• Fix the y,z translational directions (=1), 

• leave x free (=0) so contraction in the width 

direction is possible. 

• Fix the U,V,W rotations (=1). 

 

Choose an appropriate title for the boundary 

condition; e.g. “boundary conditions at holding end”.  

The save the selection with Apply and Close.  
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Loading conditions (on the top face) 

Click on the tabs Crash > Loads > 

Concentrated Loads to get the panel to assign 

nodal loads. Use the left mouse key to draw (drag) 

a box over all the nodes on the top face and click 

the Green Arrow; the selected nodes will now 

appear in the nodal list.  

 

We now set the load direction (set IDR = 2) and 

assign the loads to these nodes via a load load 

curve (in this case we shall use a linearly increasing 

curve to 1kN over 3 msec for each node). 

 

 

1. Click on LCUR and activate New. A new panel 

to define the load curve will open. Click on File 

and New  for the possibility to define the data. 

 

 
 
 
 
 

2. In the new panel define the load curve function. 

In this case x-axis is time and y-axis is applied 

load. Assume the load starts at zero and 

increases to a constant load of 1kN at 3 msec. 

The simulation time for this problem is 3 msec 

(to be defined later). Note that the applied 

loading is 1kN at each of the 21 nodes (total 

load =21kN). Finish with Assign Curve. 

 

 

 

3. Some final points: 

• The applied load could be scale if needed, 

but we shall use SCAF = 1. 

• Set ILDTYP = 1 for load to be applied to all 

nodes (this is the default). 

• Give the nodal loads a suitable title so it can 

be easily identified in the PAM-CRASH dataset 

file. 

• Make sure the load curve (LCUR) is assigned 

to this set of nodes. 

 

Finish with Apply and Close. 
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Assigning the Elastic Material and Part data 

This is done using two entities which are linked 

together; namely: 

1. The Material data for material data such as 

modulus, density and plasticity information. 

2. The Part data for (geometric data such as 

thickness). 

 

 

 

1. Material data 

Select Crash > Materials Editor and then select 

the type of Material Model; in this case use a 101 – 

ELASTIC_SHELL. Then define the material data for 

Aluminium (E=70 kN/mm2, ν=0.3 and density 

2.8*10-6 kg/mm3).  

The material assignments are closed with Apply and 

Close. 

 

 

 

 

2. Part data 

This is easily done via the explorer panel: 

1. First click on Parts and the list of parts will open; 

select the required part (=PART_1) and with the 

right mouse key select Edit. The parts panel will 

open. 

2. Set the shell thickness to H=2mm. Click just 

below H and set this to 2. 

3. Finally, the material to be linked to this part must 

be assigned. Click on IDMAT, then List and the 

materials panel will open. Select the required 

material and click OK. 

4. Give the part a sensible name. 

 

 

 

 

 

 

 

 

Finish the material/part assignment with Apply and 

Close. 
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Output results 

Some useful output could be selected (this is 

optional) 

For time history at a node click Crash > Output 

> Nodel TH and select a node (e.g. the center 

node at the loaded end) and complete the 

selection by clicking the Green Arrow. Give a 

suitable title and finish with Apply and Close. 

For the element repeat the process but using 

Crash > Output > Element TH and selecting 

the required element (for example some elements 

around the hole) which will have the maximum 

stresses. 

 

The PAM-CRASH control data must be set 

This controls the analysis and allows specific data like the 

problem analysis time (in msecs in this case), and ouput 

intervals for the results.  

 

In the Explorer panel under controls the following controls 

can be opened and edited (click on the control and open 

with the right mouse key to edit): 

1. INPUTVERSION: Set this (if necessary) to the latest PAM-

CRASH version installed and used. 

2. ANALYSIS: Open if necessary and set this to EXPLICIT. 

3. TITLE: Open and give the project a suitable tiltle (e.g. 

HoleInPlate_FullMesh Elastic); this will appear on all 

results plots using Visual Viewer and is important to help 

identify the analysis. 

4. RUNEND: Open and set this to (TIO2=3.0) for the 

solution time. 

5. OCTRL:  

a. Open and set the THPOUTPUT to POINT with 1000. 

This will save 1000 points of time history information 

for x-y graph plots in the .ERF results file.  

b. For DSYOUTPUT set option STATE with 10 to give ten  

plots of the deformed structure in the .ERF results file.  

c. In these exercises results will be saved in the .ERF file 

format. In the OCTRL panel activate type 3 without 

compression (ICOMPRES=0). 

d. Save the information with Apply and Close. 
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Saving the dataset (.pc file) 

• Save the model in a suitable 

directory/name; e.g.  

HoleInPlate_FullModel.pc.  

 

• Click on File > Export and export the 

model as PAM-CRASH input dataset.In 

this case overwrite the file, 

 

     HoleInPlate_FullModel_Elastic.pc 

 

This dataset should be complete and ready 

for a PAM-CRASH analysis. 
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Preparing the quarter (coarse and refined) analysis models for 
elastic analysis 
 

Essentially the same steps are followed for preparation of the quarter models (coarse and 

refined meshes) for elastic analysis. A brief outline and differences to the previous full model 

preparations are detailed below. These models will be analysed and results evaluated before 

moving on to the elasto-plastic models.  

 

The datasets (already copied) and to be used here are: 

 

HoleInPlate_QuarterModel_Elastic.pc     

HoleInPlate_RefinedQuarterModel_Elastic.pc  

 

For each dataset the following modifications are made. 

 

1. For each dataset start Visual Crash PAM and 

read in the file with Open File. 

 

 

 

2. For boundary conditions: 

 

Symmetry on line L1 - use 011111 conditions 

Symmetry on line L2 - use 101111 conditions 

 

where 0 and 1 are standard FE conventions 

meaning (0=free) and (1=fixed) in the 

x,y,z,U,V,W directions respectively. 

 

3. Loading on the top face is the same as the 

previous full model. But it should be noted that 

strictly the centerline node should carry only 

half the load (=0.5kN) due to the symmetry 

conditions. 

 

4. Materials and Parts information are the same 

as for the previous full model.  

 

5. Control information’s are all the same as for 

the previous full model. But you should use 

different names for the Title control card. 

Remember to save results in the .ERF file 

format; set this in the OCTRL panel - activate 

type 3 without compression (ICOMPRES=0). 

 

6. Save (overwrite) the completed models. 

 

 

 
 
 
 
 
 
 
 

L1 

L2 

y 

x 
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Part 2: Elastic explicit models: Analysis and results 
 

Running a PAM-CRASH analysis 

• Start the simulation run from the ESI 

Group Folder with the latest version 

of PAM-CRASH. 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Select the directory and your .pc file. 

It is also possible to select an SMP 

(shared memory) or DMP 

(distributed memory) version of the 

code for parallel processing and to 

select the number of processors you 

would like to run. The ‘Explicit 

Double Precision’ version is 

recommended for training problems. 

 

 

 

 

 

 

 If the dataset is good it will proceed 

through the dataset initialisation phase 

into the solution phase and terminate 

with ‘NORMAL TERMINATION’. 

 

• If there are data errors the run will 

stop with an abnormal termination 

message. Inspect the output/results 

files for errors (search for ‘ERROR’ 

and investigate). Correct the 

dataset; preferably in VISUAL CRASH 

PAM (or in the editor) and rerun the 

analysis. 
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Evaluating the results 
 
Execute the three elastic analysis models: 

HoleInPlate_FullModel_Elastic.pc   

HoleInPlate_QuarterModel_Elastic.pc     

HoleInPlate_RefinedQuarterModel_Elastic.pc  

 

Check the analyses finish with ‘NORMAL TERMINATION’ (if not check for errors, correct and rerun the 

models). For the three models it is convenient to visualise results simultaneously in one viewing 

frame. Start Visual Viewer and open results file HoleInPlate_FullModel_Elastic_RESULT.erfh5. 

Then click on windows > Page Layout and the variation shown below below. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This will open three viewing windows with the current results occupying the first window. Click on 

each of the new windows in turn (left mouse key) to activate it and then read in the remaining results 

files to each window using File and Open, 

1. HoleInPlate_QuarterModel_Elastic_RESULT.erfh5   

2. HoleInPlate_RefinedQuarterModel_Elastic_RESULT.erfh5   

 

 

 



Tutorials 3,4: Elastic and elasto-plastic loading of a plate with a central hole 

 

The next step is to synchronise the three viewing frames. Ths is done on two levels: 

1. For coupling of viewing information 

2. For coupling of state (time) plots 

 

For viewing coupling click on Window > Couple Windows to open the synchronisation panel. Then 

activate the three models and also the Views box and the options under More. This will now force all 

windows to be syncronised for zooming, viewing, contour plots, etc. Finish with Apply and Close. 

 

 

 
 

For state coupling click on the syncronisation tab shown below and then activate the three models 

to be syncronised.  Finish with Close. 
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The following is a typical set of plots that may be produced. In this case the last state (≈3msec) is 

selected together with the contour variable (Displacement_Nod_Y) to show nodal displacements in the 

loading direction. The states can be selected via Results > Animation Control, or the tabs shown 

below. The contours are selected via Results > Contour.  

 

 
 

Finally, contour plots for example of membrane stress (resultant first principle) are obtained by 

clicking Results > Contour and selecting entity type SHELL and this contour. For the full plate the 

loading resultant is total applied load/width = 21kN/100mm = 0.21kN/mm. The maximum stress 

resultant from the plot is 0.564 giving a stress concentration factor for the notch of 0.564/0.21 = 2.7, 

which is a realistic value. As expected the finer meshed model shows higher stresses. 
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Part 3:  Elasto-Plastic explicit models: Modifications, analysis 

and results 

 

Preparing the elasto-plastic analysis models 

The previous elastic model are now modified for elasto-plastic analysis. The only differences 

are made to the material law (elastic model 101 is changed to elasto-plastic model 103). The 

datasets to be copied and modified are: 

 
Copy   HoleInPlate_FullModel_Elastic.pc      

      to   HoleInPlate_FullModel_Plastic.pc            for plastic analysis 
 

Copy   HoleInPlate_QuarterModel_Elastic.pc      
      to   HoleInPlate_QuarterModel_Plastic.pc     for plastic analysis 

 

Copy   HoleInPlate_RefinedQuarterModel_Elastic.pc          

             to   HoleInPlate_RefinedQuarterModel_Pastic.pc      for plastic analysis 

 

The following gives details of the changes to be made to each of the above _Plastic datasets. 

Start Visual Crash PAM, open each file in turn and make the changes. 

 

Assigning the Elasto-Plastic Model 

1. Material data 

In the explorer window the current elastic materials 

model can be clicked and with the right mouse key 

opened for editing. In the upper selection Type a new 

materials model  103 – ELASTIC_PLASTIC can be 

selected. The existic data (E=70 kN/mm2, ν=0.3 and 

density 2.8*10-6 kg/mm3) remain valid, only a new 

plasticity curve must be added.  

 

The yield stress and plasticity information can be 

defined in a number of ways (yield stress, Curve, 

power law, …); the CURVE option is selected by 

clicking on Yield Stress and selecting the type 

CURVE; click the ‘0’ just under LC1 and New to enter 

the following curve data. 

 

In this case a simple 2 point curve is defined using: 

X – effective strain Y - effective stress 

0.0 (start of plastic strain) 0.14 MPa (= yield stress) 

0.5 0.25 

 

Then click Assign Curve. Make sure this curve 

(number 2) is assigned to parameter LC1.  

 

Finish the changes to the material assignments with 

Apply and Close. 

 

Full model 

Quarter model 

Refined quarter 
model 
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Example results are shown below for Max. equivalent stress (= Von Mises stress). The three plastic 

models have been loaded into three windows and the previous operation for syncronisation of the 

three windows has been done. 

 

The results are similar for the three cases and show that significant plasticity has occurred around the 

notch. Note that plasticity has occurred in regions that have a stress greater than the yield stress (= 

0.15MPa).  

 

One problem can also be seen in the corner loaded nodes; the deformations, stresses and 

strains are high due to high nodal loads being applied (proper uniform loading should have 

halved these loads for these nodes). It is an example how deformation and countour plots can 

be usefully used to identify modelling errors. 
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Part 4:  Implicit models: Modifications, analysis and results 
 

Preparation of the elastic and elasto-plastic models 
 

The following list the simple changes needed to convert the explicit datasets to implicit ones: 

1. Specify that an Implicit analysis will be undertaken. 

2. Specify the type of analysis; in this case either a Static, Linear analysis will be performed for the 

elastic plate, or a Static, Non Linear analysis will be performed for the elasto-plastic plate. 

3. Specify information concerning the number of loading steps to be undertaken to reach the 

maximum load (for the nonlinear elasto-plastic analysis only). 

4. Specify the element formulation to be used; in this case shell element type 6. 

5. Finally, for the full plate study only, one modification to the boundary conditions is necessary to 

prevent Rigid Body motion. 

 

As previously the safest way is to copy the explicit datasets to implicit datasets, and then modify the 

new (implicit) datasets with Visual Crash PAM. 

 

Copy HoleInPlate_FullModel_Elastic.pc    to   HoleInPlate_FullModel_Elastic_Implicit.pc 

Copy HoleInPlate_FullModel_Plastic.pc   to   HoleInPlate_FullModel_Plastic_Implicit.pc 

 

The same is done for the elastic and plastic QuarterModel and RefinedQuarterModel datasets. 

 

The following give details of the changes needed for implicit analysis. 

 

1. The implicit control card 

In the explorer panel under Controls the type of 

analysis can be changed from EXPLICIT to 

IMPLICIT.  

 

 

 

2. The type of implicit analysis 

In the main window under Crash > Controls > 

Standard Controls look in the window Type for 

ICTRL. Click this and the adjacent panel opens.  In 

the line ANALYSIS TYPE activate: 

STATIC and LINEAR for the elastic cases.  

STATIC and NON LINEAR for the elasto-

plastic cases.  
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3. The element type 

In the main window under Crash > Controls > 

Standard Controls look in the window Type for 

ECTRL. Click this and the adjacent panel opens.  In 

the line SHELL FORMULATION activate type 6.  

 

4. The solution times step (for the nonlinear 

elasto-plastic analysis only) 

In the main window under Crash > Controls > 

Standard Controls look in the window Type for 

TCTRL. For value DT2USR set 0.3. This 

parameter specifies the time step size, and is 

used to control the number of load increments 

made; RUNEND=3.0, DT2USR=0.3 giving 10 

increments (between 0 to 1kN in the nodal 

loads).  

5. Changes to boundary conditions (full plate study only) 

Boundary conditions for the quarter models do prevent any rigid body motion of the structure in both 

the translational and rotational directions. This is not the case for the full plate study and rigid body 

rotation (about the x axis) and rigid body translation (in the x direction) are possible. For an implicit 

analysis it is necessary that all rigid body motions are suppressed, so that the global stiffness matrix 

has a unique solution (i.e. the determinant is non-zero). 

Consequently, fully constrain any one of the nodes on the lower face. If only one node is constrained 

the loading in the plate is identical to the previous explicit analyses. 

Note in the explicit solution the dynamic equations of motion are solved which do not require 

suppression of rigid body modes. But clearly sensible constraints are still needed to resist applied 

loading. 

6. Export the dataset 

Finally, for each model export (overwrite) the dataset with the correct name and close Visual Crash 

PAM. 

 

Check carefully that in the preparation of these analyses models: 

• The elastic models (filename_Elastic_Implicit.pc) use the elastic material law 101. 

• The plastic models (filename_Plastic_Implicit.pc) use the elasto-plastic shell material 

model 103. 
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Implicit results for the elastic and elasto-plastic models 
 

Use PAM-CRASH Implicit to run the three elastic and elasto-plastic implicit problems, 

 

 HoleInPlate_FullModel_Elastic_Implicit.pc  

HoleInPlate_QuarterModel_Elastic_Implicit.pc 

HoleInPlate_RefinedQuarterModel_Elastic_Implicit.pc 

 

 HoleInPlate_FullModel_Plastic_Implicit.pc  

HoleInPlate_QuarterModel_Plastic_Implicit.pc 

HoleInPlate_RefinedQuarterModel_Plastic_Implicit.pc 

 

Results from the analyses are processed in exactly the same way as the previous explicit analyses 

using Visual Viewer and opening the .ERF results files. For the linear analyses there is only one 

result state which corresponds to the maximum applied load, whereas for non-linear analyses a 

deformed state is stored for each load increment in the iterative solution scheme. 

 

The following contour plots from the .ERF files show some example results for the six models. The 

figure uses a six window plot and syncronisation for the six models. The elastic studies (top row) and 

elasto-plastic studies (bottom row) show maximum equiv. stress (= Von Mises stress) for the final 

load. It can be seen that the elastic models have high localised elastic stresses at the root of the 

notch, whereas the non-linear studies show plasticity and give peak stresses at the yield stress with 

hardening. 


